TechSpot

No default gateway address

By oplinger
Feb 23, 2008
  1. I've been searching into this problem for quite some time now, and i cant seem to find any answer that works.

    Anyway, for some reason or another, i was asked to change the wireless password for my router. which is no big deal, but thats when it started, My computer (has a wired connection to the router) cant seem to connect to the router (or maybe...interface with it?) I can ping everyone on the network, but thats about all i can do through the router.

    i have restarted my computer, the router, DHCP is on, i have reinstalled my NIC's drivers, manually set the default gateway and IP and DNS, and all of them independently, ive -restarted- my DHCP services. all that fun you find in the rest of the answers i have found myself.

    my computer is the only one currently having this issue, the router works fine for the rest of them, so that leads me to believe its just myself. Does anyone have any insight? did i miss something? ...and if there is any information i need to provide i will do so.
     
  2. ScRibE

    ScRibE TS Rookie Posts: 28

    Try this from the command prompt Start => Run => type 'cmd', then press 'enter'

    ipconfig/flushdns then press enter
    ipconfig/release then press enter
    ipconfig/ renew then press enter

    please post back with the results
     
  3. oplinger

    oplinger TS Rookie Topic Starter

    no dice, just goes right back to the issue...unless i did something wrong.

    Code:
    C:\Documents and Settings\opl1nger>ipconfig /flushdns
    
    Windows IP Configuration
    
    Successfully flushed the DNS Resolver Cache.
    
    C:\Documents and Settings\opl1nger>ipconfig /release
    
    Windows IP Configuration
    
    
    Ethernet adapter Local Area Connection 3:
    
            Connection-specific DNS Suffix  . :
            IP Address. . . . . . . . . . . . : 0.0.0.0
            Subnet Mask . . . . . . . . . . . : 0.0.0.0
            Default Gateway . . . . . . . . . :
    
    C:\Documents and Settings\opl1nger>ipconfig /renew
    
    Windows IP Configuration
    
    An error occurred while renewing interface Local Area Connection 3 : unable to c
    ontact your DHCP server. Request has timed out.
    
    C:\Documents and Settings\opl1nger>
    it just...seems to have forgotten how to do things. and DHCP is enabled on the router, and on the PC. i really dont get it..
     
  4. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    the question is DHCP enabled on the NIC . Remove all STATIC information in the
    config and use dhcp for both IP and DNS.
     
  5. ScRibE

    ScRibE TS Rookie Posts: 28

    I believe you might have enter the wrong IP for your DNS, make sure that IP is correct. There is something wrong with your DNS server
     
  6. tipstir

    tipstir TS Ambassador Posts: 4,686   +86

    Follow this.. If you still need help.. just post here...

    NEW! Tipstir's Network Tweaks Blog
    Tweaks

    If you can see your workgroup PCs in MY Network Places, then you have a problem:


    To fix..

    Under My Network Places
    Set up a home or small office network
    Make sure your workgroup matches what's in there
    and continue to run..

    Next do the following...

    click on start
    click on run
    type: cmd

    type: ipconfig /flushdns
    type: nbtstat -r
    type: netsh interface ip delete arpcache

    Now go to your Network Connections
    Right click on your LAN or WLAN
    Click on Properties
    Click on Internet TCP/IP
    Click on Advance

    Default Gateway should have your DG (router)
    If not put the IP in there and leave the Metric alone.
    Click on the Wins tab
    Change Default NetBIOS
    To Enable NetBIOS over TCP/IP

    Click apply or okay

    Now...

    click on start
    click on run
    type: services.msc

    Make sure.. Computer Browsing is Enable and Started (auto)
    Make sure... Network Connections is Enabled and Started (auto)

    If you want your Router to show up under My Network Places under XP like it does Under Vista

    You need to make sure SSDP is enabled and started (auto)
    You need to make sure UPnP is enabled and started (auto)

    In your router turn on UPnP (some of you say it slows down your connections, but I don't see that happening..

    Now under My Network Places there is:

    Show UPnP Devices click on that.. If you get an error, then you need to rebuild the dbase.

    Fix is here:

    Click on start
    click on run
    type: esentutl /p %windir%\security\database\secedit.sdb

    This should this problem..
     
  7. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    security implications

    Seeing the router does not assist you in anyway to use your Lan or the Internet.
    Both SSDP and UPnP are known to cause security issues on systems and are entirely unnecessary.

    caveat emptor -- there's always pros/cons/consequences to the choices we make.

    edit: security citations/edit
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.