No hardware-accelerated Direct3D devices were found

By Ozonite
Jan 25, 2010
Topic Status:
Not open for further replies.
  1. I play this game (warrock) and when I try to start it the screen goes black and all I can hear is the sound. When I quit there's a message that says:
    "No hardware-accelerated Direct3D devices where found."

    This has happened very recently and I've been able to play this game for about 4 years.

    I've tried to reinstall the game but that doesn't work.

    I already have directX 9.0c installed so I can't reinstall it

    When I check the Diagnostic tool for DirectX in the display area there is a text saying: Direct3D acceleration: Not available

    I've tried downloading WINDOWS service package 2, which I can't get to work

    I've tried virus scan


    It is not the video card since the game has worked perfectly before


    I can't reformat the drive unfortunately since I lost my Windows XP CD.

    I'm desperate for a solution.

    Could someone please tell me how to reinstall DirectX or how to get Direct3D in some other way

    I think the problem was caused when I used a program called regrun which scans your startup and lets you delete possible malware, and I guess I deleted the wrong file.

    I'd really appreciate if someone could help me, My computer is deadslow and barely works anymore

    Thanks in advance.
    Jonathan
  2. raybay

    raybay TechSpot Evangelist Posts: 10,716   +6

    If this remains true, (I've tried downloading WINDOWS service package 2, which I can't get to work) then you are screwed.
    You need that Windows disk to repair the problem you have. And you need Service Pack 2. Service Pack 3 is optional.
    Time to spend some cash... or borrow a Windows install disk that will work with your old product ID.
  3. Puiu

    Puiu TechSpot Booster Posts: 991   +82

    This might be a driver problem. Try reinstalling them (uninstall then install).
    BTW, just download a new copy of windows xp with sp3 in it and use the cd key that your current installed windows uses (download a windows cd key viewer program to see it and copy it - google it) if it is a legal copy. If it isn't a legal copy then you need to buy it or you'll need a not so legal copy of windows.
    BTW right click on My Computer and then click properties and see what service pack you have.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.