TechSpot

No mixer devices? My sound isn't working...

By AFbusta17
Sep 30, 2005
  1. When i click on volume control it says 'no mixer devices' or something along those lines. I dont know what this means but my sound worked fine yesterday and I think I was getting those errors then also but now for some reason sound has stopped working altogether. I don't know what to do I don't know if I need to reinstall my sound card or what? I dont think I still have the disc. I got new speakers and they didnt come with a disc so Im really confused. What do i do? Im going crazy the only solution I can think of is buying a new computer but I cant really afford that. Please someone help me..........please.
     
  2. Rik

    Rik Banned Posts: 4,985

    If you fill in your profile then we will know what hardware you are using. It looks like you need to reinstall your sound drivers but without knowing what sound card or on-board sound you have we are unable to tell you where to download them from.

    Hope that helps. Rik.
     
  3. AFbusta17

    AFbusta17 TS Rookie Topic Starter Posts: 37

    ok I have a soundblaster - Creative PCI 16 or something. I like upgraded the drivers last night but its still not working. Im not sure on what else to do. My computer is about 6 yrs old but ive been getting it upgraded and stuff so its still fast and good. But yea i upgraded my drivers so i duno if thats the problem.
     
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    If you download the free Everest programme from HERE It will give you lots of info about your system, including what soundcard you have.

    If you`ve got onboard sound, then you can get the drivers from your mobo manufacturers website.

    If on the other hand, you`ve got a separate soundcard, then you can get the drivers from the soundcard manufacturers website.

    Regards Howard :) :)
     
  5. AFbusta17

    AFbusta17 TS Rookie Topic Starter Posts: 37

    I have the Creative 16 pci sound card. does that sound right? i went to the website and downloaded stuff. I think I downloaded the right things. and then i restarted my computer. do i have to like apply the downloads or something? cuz it still isnt working. :(
     
  6. AFbusta17

    AFbusta17 TS Rookie Topic Starter Posts: 37

    ok i just downloaded that everest thing and it says i have a sb pci 128 blaster. what do i do now ? its still creative.
     
  7. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    You can get your sound drivers from HERE

    Click on soundblaster, then others, and then 16 pci and click next.

    Select your language/OS/File type I.E driver, and click go.

    It`s the file at the top of the list you require. Just click download.

    Once you`ve downloaded the correct driver, just double click on it to install it.

    Regards Howard :)
     
  8. AFbusta17

    AFbusta17 TS Rookie Topic Starter Posts: 37

    when i click on sound in control panel it says there are no sound devices. why isnt it recognizing my speakers? it says pci bus 0 device 15 function 0 . i dont know what that means but it says that next to location when i click on the hardware tab.
     
  9. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    In that case just click on the soundblaster pci 128, and download that driver instead of the one I suggested earlier.

    Regards Howard :)
     
  10. AFbusta17

    AFbusta17 TS Rookie Topic Starter Posts: 37

    Thanks howard but thats what I Did and it told me to restart computer and I Did that and it still isnt working?
     
  11. AFbusta17

    AFbusta17 TS Rookie Topic Starter Posts: 37

    there r two downloads available but the 2nd one doesnt sound like anythingi'd need and even when i try downloading it i get an error about sending an error report or something. in other words it wont let me download the 2nd download.
     
     
  12. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    In that case, take out the soundcard, and try putting it in a different pci slot.

    If it still doesn`t work, then maybe your soundcard has gone bad.

    Regards Howard :)
     
  13. AFbusta17

    AFbusta17 TS Rookie Topic Starter Posts: 37

    take out my sound card how do i do that ? im at college i dont have any like tools or anything to take apart my computer :(
     
  14. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    All you need is a screwdriver.

    Make sure your computer is unplugged from the mains. Open the side panel.

    Unscrew the screw that is attached to the soundcard bracket, and then carefully pull the soundcard out of the pci slot.

    Put it into another pci slot. You may need to remove one of the case backplates for the new pci slot.

    Pop your card into the new pci slot and screw the soundcard bracket back on your case.

    Regards Howard :)
     
  15. AFbusta17

    AFbusta17 TS Rookie Topic Starter Posts: 37

    ok i put my sound card into a different slot but its as if nothing changed at ALL. wouldnt it say like something that it noticed my sound card changed ors omething? like some type of message? does it sound like my sound card is just shot? Man this is so annoying :(
     
  16. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    If you can, try your soundcard in another computer.

    This will tell you for definite whether your soundcard is working or not.

    Regards Howard :grinthumb
     
  17. AFbusta17

    AFbusta17 TS Rookie Topic Starter Posts: 37

    if it works in another computer and not in mine then what does that mean? how do i know my computer is recognizing the sound card? beacuse sound settings it says theres no audio device what does that mean?
     
  18. AFbusta17

    AFbusta17 TS Rookie Topic Starter Posts: 37

    my friend says I need a resource CD? IM confused whats that? I dont have that do i ?
     
  19. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    I`m not sure what a resource cd is :confused:

    Do you have any other pci devices in your computer, and if so are they working ok?

    If you don`t have any other pci devices. Can you borrow one from a friend perhaps just to test you pci slots are working ok?

    Regards Howard :)
     
  20. AFbusta17

    AFbusta17 TS Rookie Topic Starter Posts: 37

    i dont even know what a pci device is :( Do u think i should just buy a new sound card?
     
  21. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    A pci device is anything that plugs into a pci slot.

    I wouldn`t go buying another soundcard, as you know that your soundcard works, when you tried it in a another computer.

    The reason that I asked if you`d got any other pci devices, is to eliminate the possibility that your mobo`s pci slots are bad.

    Regards Howard :)
     
  22. Rik

    Rik Banned Posts: 4,985

    A pci device is a device that plugs into your pci slots on your motherboard. Pci stands for peripheral component interconnect, its the slot that is the most common type at the moment. Your motherboard will have at least 1 and possibly 7 or more. They are usually (but not always) black,white, or brown in colour and are mounted adjacent to the card slots in your case.
     
  23. Polaks~Pride

    Polaks~Pride TS Rookie

    I NEED HELPPP PLEASEEEE I BEGGING U GUYS. MY sound wont work it says mixer drive ... . I downloaded that everest and my motherboard id is 63-0100-000001-00101111-080103-iSPGDL_G$BF865001_BIOS DATE and its name is Intel La Crosse D865GLC ... k i know went 2 Mutimedia and my PCI/ PnP Audio device description is Intel 8280 1EB ICH5- AC'97 Audio Controller.!!!

    CAN SOMEONE PLEASSSSEEEEEEEEE email me with help my email is king_kong35@hotmail.com or add me on msn 2help cause i REALLYY need help!!! ive tried everything.. THANKSSSS
     
  24. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    Hello and welcome to Techspot.

    Try reinstalling the sound drivers for your mobo.

    You can get them HERE

    Regards Howard :wave: :wave:
     
  25. kadodo

    kadodo TS Rookie

    I have the same problem here, when I go to volume control it says that I that there are no mixer devices.
    what do I do?
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.