No signal on monitor help please

By Einherjar
Jun 30, 2008
Topic Status:
Not open for further replies.
  1. Hello I have just recently went over to a friends house and I brought my cpu along. Well we were trying to fix his and were using mine as a model to see what goes where. I opened it up and tilted it to get a good view. Then I closed it back and turned it on but the monitor said no signal. I had my cpu on earlier and it was workimg fine until now. Everything else is on just the signal thing. Could anyone help me please? It would be appreciated.
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 2,251

    Hi

    CPU ?? I think you mean your PC, the CPU is the widget inside that does the clever stuff.

    Chances are whilst transporting and fiddling in something you clearly have no understanding off you have either dislodged something or you have zapped it with static.

    However dont give up hope, it may be something simple, such as a bent pin on the monitor lead or your memory chip has come loose, you need to get a good light inside and check that all the components are seated correctly.

    Also check the add on cards havent worked loose, expecially the one for the monitor.

    Regards
  3. Einherjar

    Einherjar Newcomer, in training Topic Starter

    Thanks for the info. I'll check out those right now.
  4. Einherjar

    Einherjar Newcomer, in training Topic Starter

    I got it to work thank you for in help Mr. Smith hahahaha.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.