No sound coming through 'stereo mix' device

By Marty9231
Nov 20, 2011
Post New Reply
  1. Hi, as the title suggests I've got a bit of a sound problem:

    I wish to record some of my digital sound (e.g. my friends in Skype) using Audacity and stereo mix. However, using the built-in stereo mix record feature Audacity has, no sound is being recorded. So I checked out the stereo mix device under 'recording devices' in 'Sound' and found that it was not detecting any sound at all.

    I'm not totally sure as to how all it's settings must be, but it's like this now:

    Listen to: enabled
    Playback through: Speakers (Realtek HD Audio)

    The device is set to be 'used' ofcourse.

    Any help would be greatly appreciated...

    Marty
  2. vise

    vise Newcomer, in training

    Go to Edit -> Preferences and to the 'Audio I/O' or 'Devices' tab, and make sure the the audio INPUT is set to the source you want to hear from, in this case, the pc sound card or such, apparently Windows 7 does not change the input device when you select the Stereo Mix function for some reason.

    If that's not the case, maybe your sound driver isn't allowing the stereo mix to work, you can try the Control Panel configuring method, which you can find at the audacity website (i can't set up links yet, but go to wiki.audacityteam.org/ and add this: index.php?title=Mixer_Toolbar_Issues#Using_the_Control_Panel) [sorry for this, but it's for a good reason, i'm not a bot/spam :)]


    kind of a pain to read through and configure everything, but will fix the issue.

    If you don't want any trouble at all, you can just plug you speaker in the PC's 'Line In' plug (the blue one), and set Audacity's Input device to "Line in" or such.

    Good luck.
  3. Marty9231

    Marty9231 TechSpot Enthusiast Topic Starter Posts: 199

    Excuse me for the late reply, but I've been very busy.

    I've followed every single one of the steps you, or that website, provided and stereo mix is still not picking up ANY sound at all.
    It should pick up music playing on my pc right? Because I've used it before and it always has, until I started using a USB headset.

    By the way, I doubt that the problem lies with Audacity, because if I turn on stereo mix as default device it should be picking up my output regardless of what software I'm running. And it's not even doing that...

    Marty

    Edit: After typing the last post, I realized the only thing I hadn't done is take the headset out of the equasion. So I did, and if I use regular speakers, stereo mix works like a charm. The ONLY condition is that I have my headset speakers disabled, which is quite the opposite of what I want. I want my headset microphone to be disabled, is there any fix or workaround to accomplish this?
  4. JakenBacon

    JakenBacon Newcomer, in training

    I had the same issue.

    Stereomix installed, enabled and visible but no sound coming.

    The thing is that I was using:

    1- HDMI AUDIO OUTPUT via my GPU (plugged into my HDTV)
    OR
    2- my USB Audio Headset.
    (as my default listening device)

    I simply plugged an anolog speaker in the sound card's rear panel and used it as "default listening device" when I had to record sound.

    Problem solved.

    Seems like Stereo Mix only works when you are actually using your soundcard as default listening device.
  5. Homer10

    Homer10 Newcomer, in training

    I had the same issue as JakenBacon. I switched my sound system from an analog amplifier to a Digital Optical output. However I found that I could no longer record from the Stereo Mix source using Audacity, or any other audio recording program. I plugged in a pair of junk ear buds into the analog front R/L of my sound card, and PROBLEM SOLVED! You must also set the speaker out as the default listening device. Also the Speaker volume output, and the digital optical output volume controls both affect the Stereo Mix level. You will have to fiddle around with the levels a bit to get the best sound. If the speaker output level is cranked up too high, you will get clipping distortion. You will also get all your other analog inputs in a mixed output as well. So keep something plugged into the front R/L output jack, and enjoy all of your sound card inputs, and outputs.
  6. Giuliano

    Giuliano Newcomer, in training

    Ok dudes, I had the same problem and I finally found where the glitch was coming from. Let me explain...
    Granted that your soundcard device is fully recognized in Windows, activated and all that, and that you wonder why nothing is detected on the stereo mix when something is playing on your computer. (nothing to do with audacity, by the way).

    The problem was due to the configuration of the "Line In recording device" in Sound properties. It means you have to go in the properties of this device, BUT you have to do this with something (it can be anything, including a speakers' or headset's plug, ...) actually plugged into the Line In connector of your soundcard. Thus then, you will see more tabs in the properties window. In particular the "Listen" tab.

    This tab must be understood as playing the same role than the monitoring process in a DAW software or sequencer. Meaning, if you check the checkbox, you say to Windows itself that you want to monitor what is played through this connector/channel, and also in what you want to hear what you will be monitoring (speakers or headset, ...). And this configuration is most likely going to mess with your stereo mix output, somehow (I haven't fully understood in which practical way, but I'm sure of the symptoms), if you check the checkbox.

    SO, you absolutely need to uncheck the 'listen to this device' in the 'Listen' tab of the Line In device, if you want to be able to record something from the stereo mix, in particular if you want to do this with a headset plugged in the soundcard ouput connector.

    Hope that helps folks...

    Giuliano
  7. mimared

    mimared Newcomer, in training

    Thanks Giuliano..
    I was struggling for almost 4-5 hrs to resolve this issues with stereo-mix (win xp) for audacity-win-2.0.2.
    I tried finding the "Line In recording device" in control panel > Audio Tab > Sound play back > Volume .. the relevant check box was not checked but the volume level was set to TOO LOW, due to which the sound was not getting recorded. I increased the volume level to high and now getting sound recorded.

    Attaching the screen shot for reference (this screen is after setting, I made real and front pink visible from options > properties. This may help others also.

    mi.ma

    Attached Files:



Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.