Not detecting graphics card

By mayuresh
Jan 3, 2015
Post New Reply
  1. I purchased a new i3 pc with asrock h81m-s1 plus motherboard.
    But it is not detecting my nvdia geforce 9500 gt graphic card... It shows no display.. And in devixe manager also card is not listed

    Please help
  2. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,430   +2,822

    Make sure the system BIOS is not set to boot strictly with integrated graphics.
    nickc likes this.
  3. mayuresh

    mayuresh TS Rookie Topic Starter

    how to change the same setting? in boot setting?
  4. Vivian06

    Vivian06 TS Rookie

    Reboot your computer and press the appropriate key to enter BIOS. The key you need to use for this appears briefly on the screen as the computer boots up, but common keys are “F1,” “ESC” and “Delete.”

    Step 2
    Use your arrow keys to locate the On-board Devices, Integrated Peripherals, Advanced or Video section. The exact location varies depending on BIOS vendor and version. The appropriate menu enables you to disable or enable integrated or dedicated graphics, and may offer an auto-detect option.

    Step 3
    Enable the “auto-detect” option, if available.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...