Not receiving packets

  1. Hey y'all,
    I was wondering if any of you had any idea why when I ping google.com in terminal I get no response. I am running ubuntu 12.04. I get
    Code:
    ping -c 5 -t 5 google.com
    PING google.com (74.125.224.224) 56(84) bytes of data.
     
    --- google.com ping statistics ---
    5 packets transmitted, 0 received, 100% packet loss, time 4032ms
    and ifconfig says :
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:21:97:67:10:fd 
              inet addr:134.173.165.244  Bcast:134.173.165.255  Mask:255.255.255.0
              inet6 addr: fe80::221:97ff:fe67:10fd/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2329217 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1195340 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:3165592064 (3.1 GB)  TX bytes:201946435 (201.9 MB)
              Interrupt:43 Base address:0x8000
     
    lo        Link encap:Local Loopback 
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:2604732 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2604732 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:513411190 (513.4 MB)  TX bytes:513411190 (513.4 MB)
     
    virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00 
              inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:538 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 B)  TX bytes:25413 (25.4 KB)

    I can ping my local device (127.0.0.1) with success.
    Right now I am on a college campus where I do not have access to the router.
    Help!
    Thanks
  2. jobeard

    jobeard TS Ambassador Posts: 13,354   +302

    127.0.0.1 is the loopback interface (LO) and by definition, it is only useful for interprocess connection from
    one app to another on the same box.

    The normal interface (eth0) looks reasonable but what is this?
    virbr0 Link encap:Ethernet HWaddr 00:00:00:00:00:00

    did you manually create this? DOWN this interface and ping 8.8.8.8 should work.

    if you issue /sbin/route you will see the routing table;
    use /sbin/route >myRoutes.txt to capture that information.

    The eth0 link should have an address that is in the same subnet as your
    default route
  3. Andor Kesselman

    Andor Kesselman Newcomer, in training Topic Starter

    Thanks for the help however I still cant fix the problem. I could not find a way to down the virbr0. sudo ifdown virbr0 did not work because virbr0 is a virtual network I created and now can't figure out how to stop. Regardless, should that really affect my receiving packets. As you suggested I captured my routes and heres what I have.

    Code:
    Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
    default        rtr1-165-254.re 0.0.0.0        UG    0      0        0 eth0
    134.173.165.0  *              255.255.255.0  U    1      0        0 eth0
    link-local      *              255.255.0.0    U    1000  0        0 eth0
    192.168.122.0  *              255.255.255.0  U    0      0        0 virbr0
    
    any clues?
  4. jobeard

    jobeard TS Ambassador Posts: 13,354   +302

    you can {enable | disable} an interface thusly

    /sbin/ifconfig ifname { up | down }​

    where ifname is virbr0 and use one or the other up,down without the {}

    your eth0 IS receiving data:


    RX packets:2329217 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1195340 errors:0 dropped:0 overruns:0 carrier:0

    that other link:
    virbr0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
    inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0​
    UP BROADCAST MULTICAST MTU:1500 Metric:1​
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0​
    TX packets:538 errors:0 dropped:0 overruns:0 carrier:0​
    collisions:0 txqueuelen:0​
    RX bytes:0 (0.0 B) TX bytes:25413 (25.4 KB)​
    the HWaddr is invalid
    the inet addr 192.168.122.1 would NORMALLY be a router address
    {addresses 0, 1 & 255} have special usage and should not be used for systems.

    virbr0 {with a corrected HWaddr} would be a valid secondary NIC but I think you were attempting
    to create a virtual ip-address?
  5. jobeard

    jobeard TS Ambassador Posts: 13,354   +302

    btw: the /etc/rd.d/ has scripts used to manage resources and

    /etc/rc.d/init.d/network {start,stop,restart}​

    would be used to stop,start,restart the whole network
  6. Andor Kesselman

    Andor Kesselman Newcomer, in training Topic Starter

    very nice call on the /sbin/ifconfig virbr0 down! This does take out the virtual ip address however, it still doesn't fix my initial problem of not receiving packets.
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:21:97:67:10:fd 
              inet addr:134.173.165.244  Bcast:134.173.165.255  Mask:255.255.255.0
              inet6 addr: fe80::221:97ff:fe67:10fd/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:195005 errors:0 dropped:0 overruns:0 frame:0
              TX packets:102646 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:211973777 (211.9 MB)  TX bytes:13096726 (13.0 MB)
              Interrupt:43 Base address:0x8000
     
    lo        Link encap:Local Loopback 
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:4418 errors:0 dropped:0 overruns:0 frame:0
              TX packets:4418 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:829546 (829.5 KB)  TX bytes:829546 (829.5 KB)
     
    andor@Main:~$ ping -c 5 -t 200 google.com
    PING google.com (74.125.224.238) 56(84) bytes of data.
     
    --- google.com ping statistics ---
    5 packets transmitted, 0 received, 100% packet loss, time 4031ms
    
    If you have any other idea please let me know. Appreciate the help though.
  7. jobeard

    jobeard TS Ambassador Posts: 13,354   +302

    did you configure eth0 or let DHCP do it?

    ping your gateway (should be 134.173.165.1)

    and then use traceroute google.com to see how far you get


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.