Nvidia Control Panel does not work

By DLambie
Jan 5, 2013
Post New Reply
  1. I have Geforce 550 GTX Ti video card and my Nvidia Control Panel does not work; it worked with my old car GeForce 8800.

    Any idea why it will not workÉ
  2. St1ckM4n

    St1ckM4n TechSpot Evangelist Posts: 3,381   +607

    Define "does not work".

    Doesn't open? Can't find it?
  3. T77

    T77 TechSpot Enthusiast Posts: 315

    Try updating the drivers for it.
  4. DLambie

    DLambie TechSpot Enthusiast Topic Starter Posts: 99

    I have updated the drivers and the icons in control panel but when click on it nothing happens
  5. Dawn1113

    Dawn1113 TechSpot Booster Posts: 375   +64

    This is a long shot, but go check that your Nvidia driver's startup type under "services.msc" is set to "Automatic".

    The same thing happened to me with a beta driver once . It turned out that the startup type for the new driver installation was set to "Disabled". The startup type for your driver should be on "Automatic" by default.

    Note that you'll need to restart your PC after changing the startup type, if ever.

    Did you do a clean install of the drivers? Is your 550 Ti a recent upgrade?


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.