Only see "all types" when try to save pic from email

By Anaya
Sep 17, 2011
Post New Reply
  1. I sure hope this is the right place to put a question like this - I am so flummoxed.

    A friend sent me a [very cute] pic from her cell phone to my yahoo mail. When I open it, the picture is huge and immediately visible - no download necessary. Since i want to save it, I right click, hit save image as, and identify the location (my pictures). However, the only file types it gives me are: Firefox Document or All Types. Needless to say, saving it with either of those just gives me gobbledygook symbols. If I try to copy image, nothing at all happens - i.e., when I go to my pictures and attempt to paste, nothing gets pasted. I checked the frame info, and it says the photo is in jpeg format. Unfortunately, I can't change type over those two extension choices.

    Does anyone have any idea how to resolve this? Is there a default file extension I can change? If so, I have no idea how. Or is there a way to force it to list all available file types so I can choose jpeg?

    Any help would be greatly appreciated!

    Anaya
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,327   +49

    Often, when a picture is included 'in-line' in an email, it is also there as an attachment - which will behave normally for saving. It may be, however, that emails generated directly on a cell-phone do not support that feature. In that case, your best approach is to ask your friend to download the pic from her cell phone to a PC as an image, and attach that in an email from a 'proper' email program.
  3. Anaya

    Anaya Newcomer, in training Topic Starter Posts: 41

    change default file extensions when saving

    I think you're right - and I have asked her to resend in a different format, but I hate bugging people who have already sent it to send again. Just extra steps for her.

    Since the image in the email is identified as a jpeg, I think if I could change the file extensions available in the dropdown when I attempt to save it (i.e., somehow add .jpg to the dropdown choices) then it would save it properly. That must be a default setting somewhere...right?

    Anaya
  4. Rabbit01

    Rabbit01 TechSpot Booster Posts: 885   +39

  5. gbhall

    gbhall TechSpot Chancellor Posts: 2,327   +49

    Test - try saving it choosing 'all types' but dont give an extension yourself. It might add the extension of it's own accord. If it does not, there are several image processing programs that will cheerfully ignore the extension anyway, and examine the file itself to see if it can detect what it is.

    I don't offhand know which image manipulation programs can (or do) do this, but you could try some of the better freeware ones, like GIMP.

    You can select the file for opening by looking for 'all file types' or *.* and see what happens.
  6. Anaya

    Anaya Newcomer, in training Topic Starter Posts: 41

    Thanks to all - resolved

    Thanks everyone! I got them saved, and now know how. (Goodness that looks weird all typed out.) gbhall - i didn't do exactly what you said, but something in your suggestion made me realize what I was doing wrong and I was able to switch the extension and voila!

    Anaya


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.