OS X will not connect to wifi network

By Technochicken
Jan 25, 2010
Topic Status:
Not open for further replies.
  1. I posted a while ago asking how to connect my powermac g4 to the internet via my netbook. Since then I have gotten an airport card for the computer- one of the early 802.11 b cards that supports up to 11mb/s. I installed the card, and once I booted into OS X, the computer recognized my network along with a few others around it. But when I try to connect to the network I get the error "connection failed." When I first tried to connect to my wireless network, it had WEP security, but I have changed that to WPA personal since then, and I still get the same error.

    I know the password is correct, and the signal strength should not be an issue- according to iStumbler and MacStumbler, I get between 75 and 95% signal strength. One possible issue I have noticed is that the signal noise is around 50% at all times, but that is the same amount of noise as any other network in the area. As a note, the powermac is sitting 4 inches away from my PC desktop, which connects to the wireless network just fine.

    DHCP is currently enable, but I have tried typing in the IP adress other computers on my network sometimes use and the router, DNS, and subnet mask manually, which gave me the same results.

    I have briefly connected to an unprotected network nearby, which did not give me any errors, and I successfully got onto the internet until I lost the signal.

    Finally, the system specs are as follows:
    PowerMac G4 MDD
    1.25 GHZ PPC G4 CPU
    1.75 gb ram
    80 gb HDD
    OS X 10.5 Leopard Server Unlimited Client

    The router is a D-Link wireless N router.


    Thanks in advanced for any help!
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,419   +281

    I know this is a very basic suggestion, but it isn't totally without merit, have you tried rebooting the router?

    Also, what if you temporarily disable any encryption on your wireless, can your Mac connect then?
  3. jobeard

    jobeard TS Ambassador Posts: 13,285   +281

    hmm; unless your system supports 11.n, you need to force it into G-Only mode.
    Wire a connection from syste->router, login and disable encryption, set a new SSID,
    and force G-Only mode. Saving settings will restart the router.

    disconnect the cable and try a WiFi connection. If that works, recable and set encryption {WPA2, WPA, or only if all else fails, WEP}
  4. Technochicken

    Technochicken TechSpot Paladin Topic Starter Posts: 903

    The router has been in compatibility mode for 802.11 b/g/n, and I have not seen an option to make it only g-mode.

    Here's my exact router, in case it helps.

    http://www.dlink.com/products/?pid=530
  5. jobeard

    jobeard TS Ambassador Posts: 13,285   +281

    give it a try -- it's a known issue for many wifi adaptors ...
  6. Technochicken

    Technochicken TechSpot Paladin Topic Starter Posts: 903

    I think I am missing something. Give what a try? In the router configuration utility I can not find an option to set it to G-Only mode.
  7. jobeard

    jobeard TS Ambassador Posts: 13,285   +281

    Software loaded on the system is not the issue.
    You must use a wired connection to do the following:
    Using the IP address of the router itself, use that as the URL in your browser.

    Enter the Admin/Password and then look thru the tabs to find the WiFi config
    eg: Channel, SSID, Mode

    make the change and save the settings; then attempt a WiFi connection.​
  8. Technochicken

    Technochicken TechSpot Paladin Topic Starter Posts: 903

    That is what I did. I just tried again, but from my wireless PC, and I was still able to connect. I have found a setting called "WAN Port Speed." Is that what I need to change to switch the router's speed? Right now it is set to "Auto 10/100/1000Mbps," but there are options for 10, 100, and 1000 individually.
  9. jobeard

    jobeard TS Ambassador Posts: 13,285   +281

    no; G-Mode is a technology/frequency issue, not a bandwith setting.

    HOWEVER, if you have that choice, for this purpose, set it to 100mb. The WiFi will
    be much slower anyway.
  10. jobeard

    jobeard TS Ambassador Posts: 13,285   +281

  11. Technochicken

    Technochicken TechSpot Paladin Topic Starter Posts: 903

    It just says AirPort on it, so according to the first link it should be compatible with my Powermac, which is the Mirror Drive Door version. Also, I found the settings to change the wireless type, but I am hesitant to switch it to B only mode, as there are a number of other computers running of this wireless network, so it might not be worth it to sacrifice the speed of the rest of the computers on the network.
     
  12. jobeard

    jobeard TS Ambassador Posts: 13,285   +281

    Ah yes -- that's the delima. Suggest you look for a G or N capable device instead of the B mode.
  13. Technochicken

    Technochicken TechSpot Paladin Topic Starter Posts: 903

    I just talked to a friend- who happens to be the person who gave me the airport card- and he had an idea. He has an old airport base station, and he thought it might be possible to make a sort of daisy-chain between the two wireless routers: In other words, you would wire one of the Ethernet outputs of the D-Link router to the input of the Apple one. The apple router would broadcast it's own wireless network, and could be set to run in B-only mode, giving access to the mac. This sounds like a bit of trouble, but it actually sounds like it might work without ruining the speed of the rest of the network.

    Do you have any idea if this could work?

    Thank you for all your help so far. So much for just plugging in a mac and it working out of the box :p
  14. jobeard

    jobeard TS Ambassador Posts: 13,285   +281

    yes that CAN work :)

    wire from one router to the other using only the LAN connections and on the router last in the chain, DISABLE the DCP feature. This will force all devices (regardless of which router they connect to) to be on the same IP subnet.
  15. Technochicken

    Technochicken TechSpot Paladin Topic Starter Posts: 903

    Great! I'll probably be able to get it from him on Monday. I will post back if I have any more questions or issues with setting it up.

    Thanks again!
  16. Technochicken

    Technochicken TechSpot Paladin Topic Starter Posts: 903

    Okay, so I have got the mac connected to the internet (that is where I am typing this from). I pulled an old linksys b router from my closet and hooked it up to the d-link router. The only problem securing the network. When I put a password on the new network, I get the "connection failed" error again. That's not too big a deal thought, as I was thinking I would just unplug the linksys router when I do not need to get on the internet with the mac.

    Also, I do not really understand disabling the DCP feature like you said. Would I do this on the linksys router? I can not find an option for doing so if that is the case.
  17. jobeard

    jobeard TS Ambassador Posts: 13,285   +281

    Disconnect the linksys b router from the D-link and Wire it (the linksys b router ) to any system;
    then access the internal config page using the routers IP address. Disable DHCP there.
    Set a new SSID, say xxx-B and a channel that does not conflict with the D-Link.
    Select the Encryption and choose {WPA2, WPA, or WEP} in that order and enter a new key.
    Save the settings and disconnect from the Linksys.

    Now reconnect D-link->Linksys and connect via WiFi with the new SSID & Key
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.