TechSpot

Pagefile.sys delete

By stagg73
Jan 21, 2006
  1. I am having trouble rebooting my dell dimension which has window xp home edition installed. I originally got an error about 'not enough virtual memory' and from reading a bunch of boards, I think the issue is a corrupted pagefile.sys.

    I've gotten into repair mode by bootinf from the CD, however, when I try to delete the pagefile.sys it says it can't be found. I was, however, able to map it and it showed the following path: \Device\Harddisk0\Partition1. I then typed the following commnd into the C:\Windows prompt: delete c:\Device\Harddisk0\Partition1\Pagefile.sys. When I do that, however, it says 'access is denied'. When it originally asked me for a password logging into the repair mode, i left it blank as I have no idea of the password is.

    I'm a complete newbie, so any advice on how I'm approaching this, or how I can get myself proper access privilidges to delete the pagefile.sys, would be MUCH appreciated!
     
  2. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    password is same for normal boot
    can you boot to safe mode??
    if you can right click on mycomputer go to properties
    go to advanced performance and reset pagefile
    I don't have any page file on my 1 machine I use ram stick only
    but I guess if your Pagefile is corrupt you would get issues like this.
    and from what you wrote your ahead of me in finding this by command prompt
    so it seems just a matter of the password
     
  3. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    The password is a non-issue. If you typed the password wrong, it would NOT let you into the command line in the first place. Recovery Console only logs in as Administrator user, and most people do not have a password on that account, unfortunately.

    This doesn't matter anyway because Pagefile.sys is stored on the root of the boot partition, which you cannot edit in Recovery Console because it is outside the %systemroot% folder.

    Do as Samstoned said and, while in Windows, go into your page file settings and turn it OFF. Then restart the PC, then turn it back on, and restart again. This will give you a new file and confirm your test.
    If you still have the original problem, we can help from there.

    good luck
     
  4. xero

    xero TS Rookie Posts: 97

    deleting the pagefile.sys

    Several possibilities (boot into safe mode!).

    a) When you have enough ram >2GB, disable the pagefile in advanced system properties (rightclick my computer, properties, advanced, performance frame, settings, advanced,change, no paging file).

    b) When you dont have enough ram < 2GB but have another drive with plenty of room (in this example d:), change the pagefile location to the drive which has plenty of room (rightclick my computer, properties, advanced, performance frame, settings, advanced,change, select the d drive and copy the settings which are currently set at the c drive, when finished, select c drive and set 32 MB min and 32MB max for the C drive, apply). Windows will ask you to reboot for applying the settings, klik ok.

    c) When you dont have any other drive with plenty of room.
    1) Cleanup your temporary internet files
    2) Cleanup unnecessary documents, video, etc etc etc on c
    3) Upgrade your drive
    4) Even better, upgrade your physical ram ( when you have DDR, do not
    forget that you have to add 2 modules instead of one )

    Good luck :)

    Don't change a winning team :)
    Xero.
     
  5. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    bill gates says to do this
    1. Boot into Recovery Console.
    2. Because you boot into the %SystemRoot% folder (most commonly the C:\Winnt folder), type the following command:
    cd \
    3. Type the following command to overwrite the existing Pagefile.sys file with Boot.ini:
    copy c:\boot.ini pagefile.sys
    4. Type the following command:
    del pagefile.sys
    5. After you copy Boot.ini over to Pagefile.sys, Pagefile.sys appears in the directory listing.
    I guess you can do just about anything from cmd cnsle
     
  6. stagg73

    stagg73 TS Rookie Topic Starter

    Guys, Thanks for all the advice.

    Unfortunately, I can't even get into safemode. When I boot from the CD, it runs through a set up and then I get to a screen that gives me three options, 1) Set up Windown XP, 2) Repair using recovery console, or 3) quit setup.

    I obviously would like to keep all the files stored on my harddrive and am worried that if I choose option #1 it will wipe out all my files.

    Any advice?

    Thanks,
    Stagg73
     
  7. xero

    xero TS Rookie Posts: 97

    search for posts about "using the recovery console" and use option 2
     
  8. xero

    xero TS Rookie Posts: 97

    ps

    option 1 will not wipe out your files as long as you dont reformat the drive/delete the partition (is an option during setup)

    it will delete possibly "documents and settings", "parts of program files" and ofcourse the windows directory
     
  9. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    Ok, I wanted to figure this out once and for all.

    The Recovery Console does NOT, by default, give you access to certain areas of the system. This means you cannot, by booting off the CD, delete anything outside the regular XP system folders. UNLESS R.C. is installed to the HDD, and certain policies are in place to ALLOW access to every folder.
    When in R.C., you can set the variable needed to gain access to all folders. As per MS website instructions:
    As you can see, the default is FALSE for access outside the system directory, unless the policy is already set in your registry. SO then, should you need access to the files outside %systemroot%, type set to see what the current value is. And change if needed.

    This may have been why you couldn't delete pagefile, and maybe not.
    ---------------

    Now then, as via your last post, it sounds like you are unsure what "Safe Mode" is. Based on your problem, I don't think you need to go after any reloading option yet. You do not get to Safe Mode by booting from the CD. Take your CD out, then as the system boots, press F8 on the keyboard BEFORE the Windows logo ever appears. Just press F8 over and over until you get a menu. From there you can choose Safe Mode. And turn off the page file.
    Or you can retry the Recovery Console in light of this info, and try deleting the file again. If it is still access denied, it may just have read-only or system attributes. Use the attrib command to change those. Type help attrib to see how to use it.

    Hope that helps!
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.