Partition Problems

By Photo601
Apr 2, 2008
  1. I have a 500gb WD SATA drive, It was partitioned into three sections, boot plus two. I am in the process of installing a linux partition and I wanted to reallocate the space on the drive. I am using Partition Magic. I deleted one partition to resize the other non boot partiton. When I attempted to resize the remaining partition, PM would not do anything. It just hung there. I rebooted and tried to delete that partition to no avail. I ran chkdsk on reboot and there were no errors listed. I opened PM again and tried to check the partition for errors. The check went a short distance (Showing progress) then it hung again and eventually told me the partition had open files, and to use the oerating system to check.
    Is this a troublesome file or has my drive developed bad sectors?

    Evga 680i
    2 gb memory
    WD 500 GB SATA II
    EVGA 8800 gts 320 Graphics card.
    XP pro
  2. Matthew

    Matthew TechSpot Staff Posts: 5,261   +92

    Meh, or Partition Magic is just being lame. Try resizing it with another application (such as GParted) and see what happens.
  3. Malditohon

    Malditohon TS Rookie Posts: 16

    have you tried removing all your partitions and partition it again although its too much but have you? also linux partition are different from windows so linux should be unpartitioned first.
  4. Photo601

    Photo601 TS Rookie Topic Starter Posts: 53

    --Zenosincks, I had not heard of that particualr program prior to today. I will give it a look.

    ---Malditohon, I guess that's what I was asking advice on; If I reformat the sntire disk, then reload the image for the operating syatem. It may be a bit of work and time, but I think I am running out of options. Perhaps the program Zenosincks mentioned might work for my particular task.
    Also, I have NOT as of yet loaded the linux OS. That's what I was in the process of coing when I ran into this odd snag.
    I keep getting an error telling me the partition is in use, but there is no data whatsoever on it. It was fresh NTFS format/repartitioning. I don't understand why this is. I know if you run CHKDSK and the file(s) are in use, it will ask you if you want to do it on reboot. The partition I am trying to delete is not the primary, rather a logical one.
    I will update when I try GParted.

    Thanks to you both.

  5. Malditohon

    Malditohon TS Rookie Posts: 16

    the linux part should be unformatted type...
  6. Photo601

    Photo601 TS Rookie Topic Starter Posts: 53

    Zenosincks--I have the Gparted boot disk. Which setting do you recommend? I do not have an HP system so that rules out two settings.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...