TechSpot

PC Games running WAY too fast!

By Marjask
Jul 16, 2008
  1. This is a problem that, for most situations, I've simply turned my head away or bothered to stomach, but since it is now working with a game I wish to try, Perfect World, I have to deal with it.

    With choice games, (Gaia Online Pinball [browser game], Atari's TimeShift Demo, Perfect World), it simply runs WAY too fast. Think of it as hitting the fast-forward button on a PC game. No time to react, or anything! Here are the solutions that I've tried:

    -Fiddling around with the power management.
    -Setting the game to run on a single core.
    -Installing AMD's Dual Core Optimizer.

    Can someone help with this? It's incredibly frustrating. My CPU is an AMD 6400+ Black Edition, with 3 GB of RAM, and an NVIDIA 9600 GT graphics card.
     
  2. TimeParadoX

    TimeParadoX TS Rookie Posts: 2,438

    lol Gaia.

    Anyways... Since you installed the AMD Dual Core Optimizer it's probably something to due with the CPU Affinity.

    Press Ctrl+Alt+Delete and rightclick the game .exe in question, and click on Process Affinity. Deselect one of the cores ( 1 since you have a dual core ) and run the game on Affinity 0. Tell us if this works.

    Also, this is a personal question, You have this awesome computer but you play browser games ( lol Gaia ) and Perfect World. How come you don't play a cool game like Counter-Strike or even some crappy MMO like WoW?
     
  3. Marjask

    Marjask TS Rookie Topic Starter

    My fault for not clarifying, "setting the game to run one one core" is what you just suggested for me to do. Sorry!
     
  4. TimeParadoX

    TimeParadoX TS Rookie Posts: 2,438

    Well does it work? What I meant was turning off the Affinity core ( 1 ) and leaving on 0.
     
  5. Exhonour

    Exhonour TS Rookie Posts: 41

    How does that work I dont get it? Im not a real tech person but I still dont get how the game can be too fast :S

    Also why are you playing these crap games, sounds like your computer is quite decent. Try things like COD, CSS, WoW, GW, etc.
     
  6. Whiffen

    Whiffen TS Rookie Posts: 323

    These games were built to run with a framerate of 30 FPS. Without a cap on the framerate you may exceed the 30 FPS which would give the effect of fast-forwarding. Think of it like a movie playing at 30 Frames per second this is the normal speed, if you were to increase this rate then the movie would be playing at an above normal speed, aka fast-forward.
     
  7. Marjask

    Marjask TS Rookie Topic Starter

    'Scuse me, but Perfect World was released last May. I don't think that counts as outdated.

    Previously stated fixes work with everything but a game that I play in my browser, which still runs twice as fast. Setting firefox's affinity to a single core doesn't seem to help, either.
     
  8. chrissof

    chrissof TS Member Posts: 73

    can you put a limit to the frames per second in the driver menue?
     
  9. Nick Lee

    Nick Lee TS Enthusiast Posts: 151

    Hey I have this very same problem... I'm trying to play painkiller and its near imposable. I would like 30 FPS...or even 60 FPS... but I'm getting 150-180 FPS ;_;

    I have all the settings turned on at their highest with the res. at 1600x1200
    my specs are in my sig. but they are :
    AMD 3800+ Duel core, EVGA 7800GT, 1 gig ram, and so on....

    I would really love to fix this problem. somehow....

    [EDIT] I just tried... I love my results. get this okay. you seen my fps with both affinities... if I use just either 0 or 1 my game is in super slow motion... I mean its not lagging or stutter by any means. Its just slow motion... when I move...When I shoot....

    ;_; I just wanna play painkiller....

    But in painkiller it says I can go into the console and setmaxfps <value> but I tried this but I'm not sure if I'm doing it right... as I don't know how to type the commands. I mean I can but I don't know if its 1) Setmaxfps <60> or 2) setmaxfps 60 or 3) ....you get it...
     
  10. Nick Lee

    Nick Lee TS Enthusiast Posts: 151

    Sorry for double post(not really a double) but I did the setmaxfps command.
    I typed setmaxfps 1 as in One should be the max frame rate....
    now my frame rate is 30-70 which is a lot better than 150-180 and is more controllable... now that I think about this it did the same for the demo way back when... then one day I upgraded my video drivers and it went super fast...
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.