TechSpot

PC hangs when detecting SATA devices, but only during cold boot

By orondf
Jul 19, 2013
Post New Reply
  1. Hi,

    I recently am having the same problem every time I turn on my PC; It hangs right before displaying the connected SATA devices, but after a reboot, it works perfectly.
    I keep my PC on most of the time, so this isn't very annoying, but should I be worried about this?

    Specs: <2.5 year old PC
    Intel Core i5-2400 @ up to 3.8 GHz (Turbo Boost + OC)
    CoolerMaster Hyper 212+
    Gigabyte Z68MA-D2H-B3
    G.Skill Ripjaws X 2x4GB DDR3 1600 CL9 @ 1866 MHz OC
    On SATA Port #2 (SATA3-1): Western Digital Caviar Blue 500GB SATA3 HDD
    On SATA Port #3 (SATA2-2): LG GH24NS DVD-RW Burner
    On SATA Port #4 (SATA2-3): Seagate ST3500320AS 500GB HDDPSU: Thermaltake TR2 RX 450W
     
  2. St1ckM4n

    St1ckM4n TS Evangelist Posts: 2,920   +627

    Update mobo drivers maybe. I'd say it's mobo/SATA controller locking up.
     
  3. orondf

    orondf TS Booster Topic Starter Posts: 88

    My drivers are up to date.
    Also, I don't understand why a driver can affect something that happens before windows is even loaded.
     
  4. St1ckM4n

    St1ckM4n TS Evangelist Posts: 2,920   +627

    When I say mobo drivers, I actually mean the BIOS. This comes before any hardware or software drivers.
     
  5. orondf

    orondf TS Booster Topic Starter Posts: 88

    I have the latest BIOS as well.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...