PC slows down after inserting a cd / dvd

By GraemeWPCT
Jun 25, 2007
  1. If I am opening a large MS Excel document from the hard drive ( or busy working on the pc) and I insert a cd or dvd into the cd/dvd drive, why does my machine nearly stop everything untill the cd has been read?

    Once the cd/dvd contents is displayed in My Computer everything goes back to normal speed again.

    (It seems like the machine uses all of its resources to read a cd/dvd.)

    Question 2: is there a way to solve this?

    ACER Travelmate notebook
    2.0GHz, 533 MHz FSB, 2MB L2 cache (Intel Pentium M 760 processor)
    80GB HDD
    512MB DDR2 533 Ram
    DVD Super Muli double layer
    Running Windows XP Pro

    Ps. I get this "problem" on my desktop pc also.
  2. nismo91

    nismo91 TS Evangelist Posts: 900   +15


    it sounds that the media was goin bad...
    i mean, the discs you are using are probably in bad condition.

    I have been in this problem since i bought my travelmate too.
    However, upgrading firmware of DVD drive could give some chance of getting it fixed. for perfect example, i bought new 5 cdrw imation branded. i can't burn it using my acer travelmate (QSI dvd burner) nor my friends' acer aspire (Matshu****a DVD burner).

    But when i bring it home and burn it using LG dvd burner, it works like charm...
    it means that somehow, you need to believe that no DVD burner is reliable.
    in this case, laptop burners are worse than desktop burner.

    while mine can't do all imation discs, my friends' toshiba satellites can't do all TDK branded discs.

    So, my suggestion is, try to update the firmware of your travelmate dvd drive. i got mine updated for few times and it does show many improvement over previous version. However keep in mind that this is at your own risk.
    Neither I, Techspot nor the Firmware supplier warranty any damage ;)

    If you're interested, please provide us with your DVD drive details.
    (Right Click My Computer > Properties > Hardware > Device Manager > DVD/CD Drives > ___________ )

    Good luck... :)
  3. GraemeWPCT

    GraemeWPCT TS Rookie Topic Starter

    Nismo91: i do not think the problem is with the cd rom. The problem is that I everytime i put a disk into the drive my machine does not want to perform any other tasks until the contents of the disk has been read by the pc.

    its like the pc has a mind of its own at that specific moment in time.
  4. nismo91

    nismo91 TS Evangelist Posts: 900   +15

    ohh icic.
    i thought you're saying that your cd can;t be read
    yes, typically, everytime you insert a cd, it will autoplay by default and
    the windows will search compatible programs to open file extensions.

    as a result, before and during the reading process of the CD, your machine seems to be slower and unresponsive.

    However my computer does not stop when reading CD, unless a unreadable disc is present. usually, for my case, i don't enable autoplay,
    not even the prompt to ask you everytime new media is present...
  5. GraemeWPCT

    GraemeWPCT TS Rookie Topic Starter

    Thanks, nismo91.

    How do I disable the autoplay?

    Also, how do i get it to "not even prompt to ask you everytime new media is present"?

    Thanks for the assistance so far.
  6. CCT

    CCT TS Evangelist Posts: 2,653   +6

    HKLM-System-CurrentControlSet-Services-CDROM-AutoRun : set this value to 0
  7. GraemeWPCT

    GraemeWPCT TS Rookie Topic Starter

    Thanks, CCT

    Am I correct in assuming that this is inside the MS Windows registry?
  8. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Yes - Start, Run, regedit etc - if you aren't comfortable in there STAY OUT!

    You can stop autorun/autoplay by holding the 'shift' key in when inserting the cd/dvd and closing the door - just hold it until the lights stop blinking on the drive.

  9. GraemeWPCT

    GraemeWPCT TS Rookie Topic Starter

    Thanks for everyone's assistance.

    I am comfortable to change the registry entry. Especially since i now know what to look for and what to do.
  10. almcneil

    almcneil TS Guru Posts: 1,277

    This isn't a real problem, although you can argue it is depending on your point of view.

    It has to do with what is consider a high priority task. When you, the user, select something the system considers that the highest priority task to complete, hence, most resources are used against it until it is completed.

    To change this behaviour, do the following:

    Start -> Control Panel -> System -> Advanced -> Performance -> Settings

    Adjust them until you get the desired performance you like.
  11. GraemeWPCT

    GraemeWPCT TS Rookie Topic Starter

    Thanks, almcneil. Now i know why it happens. And i know of various ways to solve the "problem".
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...