TechSpot

PC won't boot, HD light on, CMOS battery checked

By benito72
Mar 10, 2011
Post New Reply
  1. Hi,

    Suddenly this morning my PC won't boot. I haven't changed or installed anything.
    The red HD activity light is constant, but there's no display, no beeps, nothing.

    I have removed the CMOS battery for 5 mins and also replaced it, but still nothing.

    It DID start once this afternoon just out of the blue. I shut it down, left it alone, but half an hour later it was broken again.

    Any help appreciated. Thanks. Ben.
     
  2. Lurker101

    Lurker101 TS Evangelist Posts: 736   +241

    Sounds like it might be something as simple as a static build up, although that's most commonly found in laptops. If it is, then it's easy to sort.
    Simply pull the plug on your PSU and any other ingoing power supplies, hold the power button down for approximately 30 seconds, plug your PSU back in and turn your rig on.
     
  3. benito72

    benito72 TS Rookie Topic Starter

    Thanks, but that doesn't clear it. It's odd, even if I disconnect the drives, and all the graphics, sound cards, as a bare MB it still just lights the drive light constantly, and doesn't beep or try to boot up.. I'd think it was fried somehow if it hadn't worked that one time...
     
  4. benito72

    benito72 TS Rookie Topic Starter

    I've moved onto a new pc now.. no idea what was wrong with that.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...