PC wont power up, mobo light on, but no fans, beeps, or any other activity

By grimrock
Oct 4, 2008
Topic Status:
Not open for further replies.
  1. i have a home built computer that is about 5 yrs old now but never given me any problems. i just recently bought a gig of ram, and after i installed it i tried to turn on the pc and nothing happened. i took out the new gig to see if that was it but it wasnt, still nothing. the mobo light is on, and ive checked all cables and tried swapping out the power supply and still nothing. i have no idea what to do and complettely stumped. i did smell smoke but i thott it might have just been dust. lol. its been a few weeks since it happened but i work a lot, and havent had the time.

    im running a socket 478 soyo MoBo,
    an OC'd intel p4 processor,
    a 650 watt PS,
    2 gigs of ddr ram
    (1 stick pc3200, and the other pc2700)
    a geforce 7800 gt, or gs, forgot.
    and windows3 HDD's, a normal and a slave.
    and another external.
  2. nickc

    nickc TechSpot Paladin Posts: 1,623

    what brand of psu? on a 5 year old computer that is always a question, and because the mobo light is on does not mean the power is good.
  3. grimrock

    grimrock Newcomer, in training Topic Starter

    1 was an antec, and the second one i tried was a coolmax.
  4. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.