Possible headset and mobo conflict?

By Gourry25
Apr 12, 2011
Post New Reply
  1. Well got my new PC up and running and all is good save for one thing. I have for a headset the Logitech premium stereo headset and mic, but for some reason i cannot get any sound from the headphones and mic will not work. now i earlier in the day had used the same headset on my old PC and mic and earphones worked. So unless they suddenly died on me, (soemthing i will be able to confirm in the morning). there might be a incompatibility between my new mobo and the headset.

    my current mobo is an Asus and model is M4A88TD-V EVO/USB3

    it uses for the audio realtek HD.. my logitech speakers do work but for some reason not sure why i can't get the headset to work. so if anyone knows what might be the issue please comment.

    Also if you know of a better headset with mic that will work that is not too expensive you can recommend please do so.

    finally io do have a blue tooth headset i use for my Ps3, i remember someone telling me it can be used on some Pc's but not sure if mine is one let alone how i would even go about adding it. so info on this as well would be helpful.

    Thanks in advance.


    just fixed it, needed to disable front panel audio lol. damn sorry for the post
  2. Gourry25

    Gourry25 Topic Starter

    OK i can't figure out why I'm getting echoing now in my headset though with my mic


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.