Possible Video Card Issues?

By cmstrange09
Sep 15, 2009
Topic Status:
Not open for further replies.
  1. First off, I am not very computer savvy, so please keep it as simple as possible...Thanks!


    Okay, about two weeks ago, my power supply went out, so I bought a Dynex 400w replacement and had it installed. Turned the pc on, but never explored any further than that. About a week ago, I tried logging into WoW and after about two minutes of play, my pc completely died, no warning, no error message, nothing. So I tried another game (The Sims 3), same result, but after ten minutes instead. When I stream music/videos, no problems, and playing browser games don't seem to affect it either. I have updated the drivers for my card (nvidia GeForce 7600 GT) and downloaded a program to watch the temps. The temps never went above the max or below the min.

    I have heard that sometimes when a power supply goes out, it can take other hardware with it.

    Someone help! lol

    Thanks so much!
  2. Jawshh

    Jawshh TechSpot Enthusiast Posts: 438

  3. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 4,265   +41

    When you buy new parts you should definately do research first. I wouldnt recommend that brand of psu at all. I know they sell them at BestBuy and I stay away from them.
  4. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 2,288   +7

    Maybe the card isn't getting enough juice from the PSU. Though I know its got the minimum power rating required by the 7600GT.
  5. mailpup

    mailpup TS Special Forces Posts: 8,414   +215

  6. Jawshh

    Jawshh TechSpot Enthusiast Posts: 438

    The PSU is 400W, but doesnt mean that it can actually supply 400W.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.