TechSpot

Presario v3000 screen issue

By Modena
Aug 3, 2009
  1. My sister is having a problem with her Presario v3000 laptop, she says it turns on and sounds as if everything is running as usual but the screen shows no image. It's running windows xp home, amd turionx2@1.6ghz, 1gb ram, and an 80g hard drive. Any info apreciated thank you.


    presario v 3000
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,929   +167

    It may be time to take the laptop in for service. Can you see video using an external monitor?
     
  3. Kcircyrd

    Kcircyrd TS Rookie Posts: 316

    First good test is to do what Tmagic650 suggests. Plug in an external monitor. If it runs, the problem is the backlight board.
    The screen inverter has been failing early in plenty of Compaq Presario V3000 series. - Laptop boots but screen blacks out. User can sometimes a very faint image on screen... sometimes notn. Sometimes see it better with an LED flashlight. May even come back sometimes.
    See if you can briefly see this backlight turn on when you tap rapidly on the lid close switch.
    On others the screen remains dark and the backlight never turns on, but you can still detect a dark image on the LCD.
    You may even hear noises from the base of the screen where this inverter board resides on a cable attached to the internal screen base frame.
    If so, the part can be found on eBay for less than $20, or at HP for $59, but it is damnably difficult to replace. There are about 24 screws, and most are hidden by screw hole covers.
    Still, using a very high quality philip screwdriver and a sharp tool to lift off the screw covers, you can replace it in less than an hour.
    Repair shops in the USA charge about $150
     
  4. lamo

    lamo TS Rookie Posts: 570

    ..or you can replace nv6150go :) but yes, agree, symptoms for it's death are quite unusual.
     
  5. Modena

    Modena TS Enthusiast Topic Starter Posts: 182

    *UPDATE* Well sorry for not responding to the earlier posts but the laptop was in Cali and now I actually have it in person in Connecticut. When I hit the power button the lights come on I can hear the dvd-rom make a sound as if it were booting up, hd activity light hardly flickers then stops, all while the screen is completely black not even backlight or anything. dead hd? fired mb? faulty ram? bad screen/screen connector? Also the screen was recently replaced (about 3months) because last one was damaged, so its a new replacement screen.Thats basicaly it nothing happens after that point once again any ideas or info would be great, thank you.
     
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,929   +167

    The motherboard is probably fried... Remove the hard drive and reseat the mermory... try starting
     
  7. Modena

    Modena TS Enthusiast Topic Starter Posts: 182

    Removed hard drive and reseated memory and nothing. So its safe to say its a fried mb and thats what i have to replace? thx for the response
     
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,929   +167

    Yes, I think it is the motherboard...
     
  9. Modena

    Modena TS Enthusiast Topic Starter Posts: 182

    IGNORE THIS trying to see if its ebay thats not allowing me to embed an image

    [​IMG]
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.