TechSpot

Print Spooler will not start

By sol1109
Nov 16, 2012
Post New Reply
  1. Spent about 10 hours trying to resolve a network printing problem on a laptop today and now I am asking for your help. The HP laptop stopped printing with the message "Print Spooler is not running". I tried starting it at services.msc but it will not start. I tried uninstalling the printer from add/remove and could only remove the printer applications but the driver will not uninstall because the print spooler is not running. I tried reinstalling the printer but it will not because the spooler is not running. I tried installing a different printer with the same failure. Microsoft FixIt identified the spooler as not running, tried to start it and it failed immediately. FixIt said it could not help. I checked windows update and it is up to date. Printers work with 4 other pc's on the network. OS: Win 7 Pro
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,426   +317

    Treat it as if there are jobs in the print queue that can't be deleted. As I recall you delete the subdirectory in the Spooler directory used for that specific printer.

    Try running this troubleshooter

    === Update ===
    Here's another Wizard
     
  3. sol1109

    sol1109 TS Member Topic Starter Posts: 91

    Thank you for your reply jobeard. I had tried that but on your sugestion I retested using the troubleshooter. See the attached file for the results.
     

    Attached Files:

  4. jobeard

    jobeard TS Ambassador Posts: 13,426   +317

    Data execution prevention.
    I have added the print spooler service to the excluded list and it has solved the problem.

    For Win/7 see this

    Others, right-click My Computer->Properties>Advanced
    • Select Performance>Settings
    • Select Data Execution Prevention
    • Select Turn on DEP for all programs and services except those I select
    • Click Add
    • Paste this in to the file name box of the window that opens:
    • C:\WINDOWS\system32\spoolsv.exe
    • Select Open
    • Select OK when you receive the warning
    • Select Apply
     
  5. sol1109

    sol1109 TS Member Topic Starter Posts: 91

    When selecting OPEN for spoolsv.exe I get the msg: You can not set DEP attributes on 64 bit executables.
     
  6. Pan Wah

    Pan Wah TS Enthusiast Posts: 134   +27

    This can happen due to conflicts with IE add-ons, suggest temporarily disabling them, and if this solves it, enabling one by one to identify the culprit.
    Good luck ;)
     
  7. jobeard

    jobeard TS Ambassador Posts: 13,426   +317

    hmm; think about this a bit. The Print Spooler is a system level service and gets started at boot time.
    The browser - - any browser - - starts only when the user invokes it and the print server should already be active.
    Therefore, the browser has no interaction to start this service and add-ons are not related.
     
  8. Pan Wah

    Pan Wah TS Enthusiast Posts: 134   +27

    Ok, sorry sol, the times that this has happened (and were resolved by the above process) were imaginary, and I've made a fool of myself, just ignore me, jobeard will see you right.;)
     
  9. sol1109

    sol1109 TS Member Topic Starter Posts: 91

    Thank you all for your input. After my son completed his finals we decided to perform a complete restore as suggested by HP support. His problem has been resolved. Happy Holidays to ALL.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.