Problem loading websites

By Popino
Mar 14, 2013
Post New Reply
  1. Hi. I'm having some problems loading websites on any browser, they won't fully load or their images look all weird, and the same thing happens to steam. This is weird because I have a good internet connection and some websites I have no problem loading. bf3.jpg youtube.jpg
  2. JC713

    JC713 TechSpot Evangelist Posts: 6,725   +874

    No problem. What browser version are you using? What is your internet speed? And what are your system specs?
  3. Popino

    Popino Newcomer, in training Topic Starter

    I'm using chrome version 25.0.1364.172 but it happens on IE too.My internet speed is 100Mbps and I never had this problem, but I recently changed my internet provider and wireless pen but still this only happened like yesterday. With incognito mode the page won't fully load aswell but the images don't look so 'trashy'. Really don't know what to do :s
  4. JC713

    JC713 TechSpot Evangelist Posts: 6,725   +874

    What are your system specs? It may be a GPU acceleration issue. What GPU driver are you running?
  5. Popino

    Popino Newcomer, in training Topic Starter

    I'm using an intel i5 3570k driver 6.1.7600.16385.
  6. JC713

    JC713 TechSpot Evangelist Posts: 6,725   +874

    That is your CPUs chipset version, tell me what graphics card you are running (ex: GTX 680, AMD Radeon 7970, etc.)
  7. Popino

    Popino Newcomer, in training Topic Starter

    Oh yeah sorry my bad, Yeah it was weird you asked for driver version of my cpu but it was gpu lol sorry. My gpu is an ati radeon hd5770 1gb driver 12.100.17.0 catalyst 13.3 beta I guess. Thank you for the replies.
  8. JC713

    JC713 TechSpot Evangelist Posts: 6,725   +874

    Are you running the 13.3 beta that was released on friday? If not, I have options.

    Edit: After looking at the latest release notes, it doesnt look like there are any bug fixes associated with your issue.
  9. Popino

    Popino Newcomer, in training Topic Starter

    Hey man thank you so much for the reply but I figured it out, I just downgraded the wireless pen driver and it's all cool, still pretty stupid since new drivers should improve performance but oh well now it's all good thank you :)
  10. JC713

    JC713 TechSpot Evangelist Posts: 6,725   +874

    New drivers do improve performance 90% of the time, but bug fixes are also very crucial. Glad you got it fixed. BTW, 13.3 Beta 2 was released today.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.