Problem: Username and password when trying to connect to other computer

By ryan29121
Oct 6, 2009
Topic Status:
Not open for further replies.
  1. Hello I have a networking problem. Whenever I try and connect to my other computer I get a username and password prompt such as the one posted below this message. The computer I am trying to connect to has Windows 7 installed and this computer has windows xp. I had this same problem when there was vista installed instead of windows 7. Everything in sharing center is marked as shared, firewalls turned off, and I am connecting wired through my router. My windows 7 computer can connect to my laptop but not the other way around. Does anyone know of a solution to this problem? Thanks in advance for your help regarding this issue.
    [​IMG]
  2. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,284   +153

    Start by assuring the account info (both Userid and password!) are identical for users on both machines. Specificaly check user accounts for: Guest and Nicola (redefine their passwords to assure identical)
  3. ryan29121

    ryan29121 TechSpot Enthusiast Topic Starter Posts: 182

    I have no password set up for windows 7 so I dont think that could be it. Also guest account I believe should be disabled by default, in which I do not have active. Any other suggestions?
  4. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,284   +153

    Do you have "no password" set up for the same userid on the other computer?? If the userid/passwords mismatch on the two computers it can be a problem

    Also disabling Guest only means you can;'t use Guest for local logon. Windows will still use Guest account for remote logons to a computer which set for Simple File Sharing.

    /* Edit */
    Note windows uses the userid/password of the client computer to try and remote logon to remote computer
  5. ryan29121

    ryan29121 TechSpot Enthusiast Topic Starter Posts: 182

    both my laptop and win 7 computer have no password set up. Windows just auto logs in when i start the computer up. I dont know why its asking for a password. DO i have to set one up to get around this?
  6. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,284   +153

    Let me give you the easy answer first (then we can discuss why Windows does this and how to change it if need be)

    Assign the same userid the same (non-blank) identical password on both computers. Does that fix the problem?

    /* edit */
    And, btw, when you get the prompt, are you successful at manually logging when it prompts for remote logon userid/password
  7. ryan29121

    ryan29121 TechSpot Enthusiast Topic Starter Posts: 182

    setting up a password for win 7 worked. I just wish I didnt have to type in a password every time I started the computer up. Thanks for the help by the way.
  8. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,284   +153

  9. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,284   +153

    So here's some info....

    First, terminology:
    Windows remote network access works in a client/server model
    • The "client" is the computer you log into locally
    • The "server" is the remote computer you are trying to access
    Also, Windows supports two different file sharing models
    • Simple File Sharing (SFS) and
    • Non-Simple File Sharing (Non-SFS)

    The file sharing mode on the server controls the method of Windows remote logon
    > If the server is configured to SFS, then Windows remote logon requires valid Guest account logon
    > If the server is configured to non-SFS, the Windows remote logon requires a valid user account logon

    By definition, XP Home edition ONLY supports SFS. It can not be configured non-SFS
    You can check the other Windows versions by opening Explorer in XP. File/Folder options for Vista and (i think) Windows 7.
    > Click the View tab
    > Scroll through the options toward the end and look for Use Simple File Sharing
    ===> If the option isn't there, Windows is running SFS
    ===> If the option IS there, you can configure for SFS or non-SFS (is up to you)

    Make any sense so far? Check for SFS or non-SFS on each of your computers and get back to me. This option lets you change the account logon requirement.

    Also on each computer try clicking Start->Run, enter gpedit.msc. This is the group policy editor. It isn;'t available for XP Home. Check for your other Windows versions. If the group policy editor exists, it will let you change whether a blank password is allowed or not for remote logon to the server

    /* edit */
    You might find it simplest/easiest to run SFS on all your computers. It sounds like your Windows 7 machine is configured to non-SFS since Windows is prompting for remote log on with a user account (not Guest account)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.