TechSpot

Problem with Acer aspire 5720 keyboard

By auntyjack
Apr 3, 2008
  1. Posting on behalf of my girlfriend...

    Not sure if it's software or hardware, but she's having an issue with aforementioned notebook keyboard - basically when she's typing in Word and gets up to a reasonable speed, the cursor will jump to an earlier part of the document and words will start to highlight.

    Any ideas?
     
  2. raybay

    raybay TS Evangelist Posts: 10,716   +6

    Usually the best fix is to replace the keyboard... about $30 to $50.
    Try cleaning it thorougly with a can of difluoroethane gas such as dust off, as sometimes they are just dirty.
    You might also attempt disconnecting and reseating all relevant cables.
     
  3. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Good advice. (regarding cleaning and blowing out any dust)

    I've also seen this a lot on laptops, where the user either mistakingly touches the mouse touchpad, or the touchpad is too sensitive to vibration.
    Disabling the touchpad or reducing the sensitivity can avoid this
     
  4. auntyjack

    auntyjack TS Rookie Topic Starter

    Thanks raybay - but it's only about 3 months old and not very dusty so I don't think the keyboard needs replacing yet.

    I thought that it was something to do with the touchpad as well - looked at the control panel for the touchpad and there is a setting to disable "tapping" on the touchpad while you are typing on the keyboard. Turned that on and we'll see if she has any more problems.

    thanks!
     
  5. Samputer

    Samputer TS Rookie Posts: 23

    i have this alot on my acer too but im pretty sure its myself just slightly catching the touchpad - i think it must be just the position of it on these laptops
     
  6. syedejaz

    syedejaz TS Rookie

    Yes I have the same problem. I bought 5920G for my brother he is also having the same problem. Also one of our teachers has 5720G he is also having the same problem.
    I noticed that the problem is due to Touch pad. Try to disable the touch pad by pressing Fn + F7 you may be able to write as I have done.
     
  7. syedejaz

    syedejaz TS Rookie

    No my friend.
    some days before a tea was spilled on my keypad and it became spoiled. I replaced the keypad with a brand new one. First I thought that it might also solve my problem as mentioned here. But, I have the same problem. There was no dust it was brand new. Now I have disabled the touch pad. I m using external mouse. Its sound to be good now. I can type without having problem.
     
  8. pyc

    pyc TS Rookie

    There is one software to disable the touchpad while typing... PM me for the name...
     
  9. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    To turn off the touchpad when an external mouse or other pointing device is present, you can goto the Control Panel and double click the Mouse properties icon.

    Click the Device Select tab and check "Disable Touch Pad when USB Pointing Device is present." The cursor will no longer move via the touchpad.

    No PM required!
     
  10. raybay

    raybay TS Evangelist Posts: 10,716   +6

    Thanks, Kimsland. Beat me to it.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.