Problem with adding a second router to the network

By tufahija
May 29, 2010
Topic Status:
Not open for further replies.
  1. Hello,

    I have a Cable/DSL connection at home and my TrendNet router was connected to the cable modem. I had three computers in a wired local area network. Recently I bought a Toshiba notebook and a Belkin Wireless G router. Since two computers are desktop and other two are notebook I want to add the router to the local area network in such way that all of them remain in the same network I (because of the file and printer sharing) and I want my notebooks to be able to connect to the router using wireless connection.

    I spent two days trying to setup the local network but I never managed to configure it the way I want it to be. Two scenarios happened.

    In the first scenario, my desktop computers had 192.168.1.xxx addresses, and my notebooks had some strange address and subnet when connected using wireless and they couldn't use neither local network nor internet. When I connected them to the router using wire they also had the 192.168.1.xxx address and worked fine.

    In the second scenario, I managed to connect my notebooks to the router using wireless connection but in that case they had the 192.168.2.xxx addresses and cannot see my two desktop computers as a part of the Windows network. Ping works fine and I can access desktop computers using \\192.168.1.xxx from the Run dialog. But none of the desktop computers could either ping or access any of the notebooks.

    Can anyone help me solve the problem?

    Thank you in advance.

    Tufahija
  2. Leeky

    Leeky TechSpot Evangelist Posts: 4,378   +98

    OK, just to confirm, your using your TrendNet router AND your Belkin wireless router?

    Assuming both are for DSL connections, is there any reason why you need to use two routers?

    If your TrendNet router isn't wireless, then remove it completely, and use the Belkin one that is.

    If you must use both, then you need to configure the Belkin router as a wireless access point and network switch only, and disable DHCP and UPNP in that router.

    So the following should see you sorted:

    1. connect the Belkin router to your TrendNet one via ethernet cable.
    2. Do a hard reset of your Belkin router (so you have a clean base to set it up)
    3. Log into the router, and then disable DHCP
    4. Disable UPNP.
    5. Set up wireless as usual.

    This is usually enough to setup a router as an access point. Some models need slightly different procedures though. You do NOT want DHCP or UPNP enabled on the Belkin router though. You want your TrendNet router to assign IP addresses from its IP address pool to devices connected to your Belkin router by either wired, or wireless connections.
  3. tufahija

    tufahija Newcomer, in training Topic Starter

    I already tried turning DHCP off and using "Use as an access point" option in Belkin router control panel. After I turn this option on, when I connect my computers to the router using wire everything works fine. If I try connecting using wireless they get some weird IP and subnet addresses and they can't connect to the internet nor the local network :S
  4. Leeky

    Leeky TechSpot Evangelist Posts: 4,378   +98

    IS there any reason why you can't just swap routers around?

    Or use the DHCP server on the Belkin, and make the Trendnet router your 2nd one.
  5. tipstir

    tipstir TS Ambassador Posts: 4,604   +80

    Make sure the Belkin has a static IP address. No need to swap the routers around.
  6. tufahija

    tufahija Newcomer, in training Topic Starter

    So, what do you suggest I should do before setting its IP to be a static one?
  7. tipstir

    tipstir TS Ambassador Posts: 4,604   +80

    I use trendnet TEW-673GRU as the main DHCP Server (Router) and then I use Belkin N+ in AP mode.

    So the trendnet you have should be setup normally DHCP and the range usually 192.168.x.100 thru 192.168.x.200

    So pick a number in the range above let's say 192.168.x.180 note the x is the number you use I would recommend changing it from the default. Option. Anyway the static should look like this:

    IP address: 192.168.x.180
    Subnet Mask: 255.255.255.0

    That's about it for static IP

    SSID: create one (let's say mynetG)
    Passcode: create one (let's say: flymetothemoon1980)
    Security WPA2/AES
    Mode: G or Mix
    Channel Auto
    Channel Wide: Auto

    Once the the above is all saved, then you just walk over your laptop and see if can see well in my example would be mynetG (your name will vary) Once you found the wireless network. Then click on it then it will ask you for passcode. Just type that in.

    Note: WPS is another way to do all of this. But there is issues with that feature. I say to disable it first. Then setup a manual wireless protection yourself. Like I have explain above. That's what I do here. I don't know which model of Belkin G you have? The black version are easy to setup. Grey versions might be tricky.
  8. jobeard

    jobeard TS Ambassador Posts: 13,337   +293

    hint: the trick is to cable router#1.lan to router#2.lan and leave router#2.wan empty

    now disable router#2 DHCP and all IP config will be controlled by router#1 DHCP and no
    static configuration is necessary at all (wired or wireless).
  9. tipstir

    tipstir TS Ambassador Posts: 4,604   +80

    Joe,

    Belkin has AP mode there is no need to disable anything on the Belkin. It's done automatically and removes all those menu items that are needed for the router.
  10. tipstir

    tipstir TS Ambassador Posts: 4,604   +80



    Belkin has AP mode there is no need to disable anything on the Belkin. It's done automatically and removes all those menu items that are needed for the router.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.