1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Problem with ATI Radeon X300 Display Drivers

By SFlpm
Dec 28, 2008
  1. I recently decided to update my ATI Radeon X300's display drivers, which updated and installed fine. But when I went to restart my computer it loaded to the desktop just fine. But once my desktop loaded, my computer restarted. It continues to loop this until I either go to Safe Mode or turn my computer off. After a while, I figured out that it was my display driver that was causing the problem. So I uninstalled my display driver in Safe Mode and restarted my computer. It worked just fine, but I couldn't run any games. I would like my computer to be able to use my graphics card, but every time I reinstall those drivers my computer goes back to the same problem. If anyone could help me that would be great. If anyone tells me to use a older version of the display driver, please post a link.
    Thanks.
     
  2. adweston

    adweston Banned Posts: 242

    It kinda sounds like the card is faulty. I'm not saying that's for sure the case, but that's what it sounds like.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...