Problem with CD ROM Drive

By Transform
Aug 8, 2009
Topic Status:
Not open for further replies.
  1. I have been having issues recently with my CD ROM drive. If I use a disk in the drive the computer will freeze up if left idle too long. In the event viewer I have the following:

    Event ID 11: The driver detected a controller error on \Device\Harddisk1\D.

    I have since disconnected the drive and have had no problems for a couple of days now. Is there a fix for this? It would be nice to use my CD drive again!
  2. Tekkaraiden

    Tekkaraiden TechSpot Maniac Posts: 880   +52

    Sounds like you might have a failed cdrom drive. If possible try to plug the cable into another available ide or sata connector (depending on how it connects). If you have a ide/sata to usb adapter you might want to try connecting the drive through usb as see what that does. That will rule out a bat ide or sata connection.

    I have a Pioneer DVD burner that likes to do this from time to time. I finally got tired of it and replaced it with an LG model. My computer's been happy ever since.
  3. Tedster

    Tedster Techspot old timer..... Posts: 10,067   +13

    failing drive? replace it. They're cheap.
  4. Transform

    Transform Newcomer, in training Topic Starter Posts: 70

    I just changed the IDE cable. All is good so far but I'll monitor is this upcoming week.
  5. Transform

    Transform Newcomer, in training Topic Starter Posts: 70

    Happened again today. I got this error many times over:

    An error was detected on device \Device\Harddisk2\D during a paging operation.

    Looks like my CD-ROM drive is faulty?
  6. Transform

    Transform Newcomer, in training Topic Starter Posts: 70

    Got myself a new DVD drive and its still happening. Is it possible that it could be the IDE connector on the board that is the issue here?
  7. blerina

    blerina Newcomer, in training

    yeah could be...you should check that.

    did you touch the drivers by any chance?? that can be a problem too

    go check on device manager, and see if the drivers look ok, and if u can, update them and see if that helps :)
  8. Transform

    Transform Newcomer, in training Topic Starter Posts: 70

    they are the standard microsoft drivers. does that help?
  9. blerina

    blerina Newcomer, in training

    yeah thats what I was talking about. so the drivers are ok, then the problem must be in the IDE connector.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.