TechSpot

Problem with Game lag

By redwinger
Feb 24, 2008
  1. I play crysis, battlefield 2142, call of duty 4 and ither high end games on the highest setting and they run great but when i play halo2 on any setting the game will skip jump ang lag big time. it never did b-4 it just startd and it is only isolated on the halo 2 game. also some times my internet explore window will freeze and get stuck i have to control alt delete then cancel out of it and then it unfreezes and i can x out or cintinue using ie. is this related to my halo 2 problem as well. i did a full os delete and reinstall and it didnt help in running vista tried installing older drivers and nothing has worked. it only does this on halo 2. here is what my comp has:
    Manufacturer:
    MSI 7350 P6N
    Processor:
    Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz (2 CPUs), ~2.4GHz
    Memory:
    4092MB RAM
    Hard Drive:
    250
    Video Card:
    NVIDIA GeForce 8800 GTS
    Monitor:
    Samsung SyncMaster 931BF 2ms 2000:1
    Sound Card:
    Speakers (High Definition Audio Device)
    Speakers/Headphones:
    Klipch 7:1 Surround
    Keyboard:
    USB Root Hub
    Mouse:
    USB Root Hub
    Mouse Surface:
    Teflon
    Operating System:
    Windows Vistaâ„¢ Home Premium (6.0, Build 6000) (6000.vista_rtm.061101-2205)
     
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

  3. redwinger

    redwinger TS Rookie Topic Starter Posts: 57

    i did check the faqs and guides prior to posting and did see your link and tried all those prior so i posted this new thread.
     
  4. wanna be geek

    wanna be geek TS Rookie Posts: 80

    Go to the short ct of this app and right click, then clik properties, click on Compatibility, check the following... Disable desktop compisition
     
  5. redwinger

    redwinger TS Rookie Topic Starter Posts: 57

    There is no option to do that. does vista not have that option?
     
  6. Acclamator

    Acclamator TS Rookie Posts: 261

    Wrong forum.
     
  7. wanna be geek

    wanna be geek TS Rookie Posts: 80

    Yes it does have that option and I solved that prob with that same fix... Once again. Go to the shortcut, Right click, click on properties, click on compatibility, click on disable desktop compisition...
     
  8. redwinger

    redwinger TS Rookie Topic Starter Posts: 57

    here is a screen shot of it.
    [​IMG]
     
  9. k.jacko

    k.jacko TS Rookie Posts: 493

    Click on 'Open File Location'. Basically get the properties of the original .exe not the shortcut, then choose the compatibility tab
     
  10. wanna be geek

    wanna be geek TS Rookie Posts: 80

    this is what you should see when you do that...
    [​IMG]
     
  11. redwinger

    redwinger TS Rookie Topic Starter Posts: 57

    ok i found it and clicked the disable desk top compatablity and started a game and it still does the lag and skips just like it did b-4 :(
     
  12. wanna be geek

    wanna be geek TS Rookie Posts: 80

    Uk, now go to this link and follow the instructions and download the forceware for your video card and configure it to best performance...
    http://www.nvidia.com/page/home.html
     
  13. redwinger

    redwinger TS Rookie Topic Starter Posts: 57

    did that still laggy and skipping no difference. :(
     
  14. wanna be geek

    wanna be geek TS Rookie Posts: 80

    Try to disable ALL start up programs as well as anti virus stuff... Then go to "computer", right click... Go to advanced performanced settings link on the left,
    5hen when the new window opens click o0n performance and check Run At best performance... Click apply... Another option is to get a flash drive and use ready boost... Let me know how you do
     
  15. redwinger

    redwinger TS Rookie Topic Starter Posts: 57

    still laggy.
     
  16. wanna be geek

    wanna be geek TS Rookie Posts: 80

    Ok, go to the Halo site and download the patch... Ther is a post about the prob you describe... You must update your game.....
     
  17. redwinger

    redwinger TS Rookie Topic Starter Posts: 57

    can you send me the link?
     
  18. redwinger

    redwinger TS Rookie Topic Starter Posts: 57

    I got it fixed!!! it wasnt a patch problem it was i had to force v-sync on in my nvida control pannel in the advanced settings.but without out you I wouldnt have gotten the info i needed from others. thank you very much for your help and patience and multiple replys to my noob thread. ;-)
    heres what i had to do:

    For Nvidia users:

    1. Right click on your desktop
    2. Click NVIDIA Control Panel
    3. Select Advanced Settings
    4. Click Manage 3D Settings
    5. Click on the Program Settings Tab
    6. Click Add
    7. Select halo2.exe ( c:\program files\microsoft games\Halo 2 )
    8. Scroll to the bottom of the settings for Halo2.exe and force Vsync ON
    9. Click Apply
    10. Play!
    [​IMG]

    For ATI users:
    1. Right click on your desktop
    2. Click ATI Catalyst Control Center
    3. Click on 3D
    4. Click on All Settings
    5. Scroll down to "Wait for vertical refresh"
    6. Move it to the right until it says "On until application specifies"
    7. Click Apply
    8. Play!
    [​IMG]
     
  19. Pesh

    Pesh TS Rookie

    Nice pc you got there but if the Vista is yours.. screw it! :D
     
  20. redwinger

    redwinger TS Rookie Topic Starter Posts: 57

    yea vista is a lil buggy but halo 2 will only run on vista and if I want direct 10x graphics I have to run vista.
     
  21. wanna be geek

    wanna be geek TS Rookie Posts: 80

    Unless you are posting a question or asking for help, don't bump a thread for useless crap comments or you will be banned.... No
    one needs your BS..
     
  22. tweakboy

    tweakboy TS Guru Posts: 467

    Stop playing the game, or stop using Vista lol , both are a cardinal sin , Say asta la vista to billys new junk OS, and go with whats proven,, XP hehe,,
     
  23. redwinger

    redwinger TS Rookie Topic Starter Posts: 57

    just wanted to thank you all for trying to help me with my problem with halo 2. THANKS!!!
     
  24. redwinger

    redwinger TS Rookie Topic Starter Posts: 57

    Ok the problem is back again and it seems like everytime i add a new game to my comp it gets even worse. and it dont effect anyother game but halo 2. could it be a hard drive issue or am i just stuck with this. it went away after the abouve described fix but came back about 2 weeks later. ;-(
     
  25. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...