TechSpot

Problem with Internet connection

By chow1012
Feb 24, 2006
  1. My PC is connected to the Internet via a DLink router and a cable modem. My hard disk has 2 bootable partitions and a D: partition which is for data storage. Both bootable partitions have WinXP installed. Let me call it WinXp1 and WinXP2. I usually use WinXP1. WinXP2 is just for testing purposes. I don't have problem connecting to Internet with WinXP1. However, WinXP2 failed to connect. When I did a 'Repair', it reported a problem saying that it wasn't able to get the IP address. There is an "!" on the icon when I opened the network connection.
    Then I went to the Network Connections of the Control Panel and set a static IP address. The "!" on the icon is gone. I tried a "Repair" and I saw it was doing some "Clearing...", "Refreshing...", and "Registering...". It seemed like that it was able to talk. But when I started the Internet Explorer, I wasn't able to browse. The status line at the bottom showed that it wasn't able to locate the server.
    Since I don't have problem with WinXP1, I assume that there is no hardware and connection problem. To me it seemed like there was some incorrect settings. Appreciate if somebody could help.
     
  2. Rik

    Rik Banned Posts: 3,814

    Check to see if you browser is set to "work offline". Take the tick out if there is one and that could fix it.


    Rik.
     
  3. sw123

    sw123 TS Rookie Posts: 595

    Well, i havent seen that before, but...

    Try these:

    Make sure the cables are firmly attached to the router and computer.

    Make sure the lights on the cable modem are all on and green or whatever color they should be.

    Make sure you have an account set up with your ISP

    Try disabling any firewalls you have on

    See ya
    sw123
     
  4. SuperKoopa

    SuperKoopa TS Rookie

    Something sort of similar happened to me. It was because my computer was reading the router's ip as a completely different one and couldn't find the right ip. Check to see if you can ping the router. If you can, that's good. (To ping, go Start -> Run -> CMD -> ping <router ip> and hit enter). If you can't, check to verify your computer is on the router IP's accessable list-ish thing with the correct IP address. Then reset your router, and try to ping it again. Hope it helps.
     
  5. Spike

    Spike TS Evangelist Posts: 2,168

    Also make sure that you've set the "default gateway" to your routers address.
     
  6. jobeard

    jobeard TS Ambassador Posts: 9,334   +622

    if you can ping the router, your NIC is fine.
    if you try "run->cmd /k nslookup google.com" and it runs, your browser should too. If it fails, then the DNS address is bad/bogus or not set.

    try ipconfig /all to view settings
     
  7. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    uninstall drivers and reinstall for that system corrupt drivers???
    start the machine in good os and download firefox
    open the test system run firefox setup to browse net with this
    should be using firefox anyway
     
  8. chow1012

    chow1012 TS Rookie Topic Starter Posts: 17

    If I set to dynamic IP, then I can't ping the router. However, if I set it to static IP address (192.168.0.102) then I can ping the router. Both waysm it failed "cmd/k nslookup google.com". It couldn't find it. Since the internet in my other partition works, I think it is safe to rule out the possibility of having problem with the NIC, computer, cable, connections, router etc.
    I started to suspect the possibility of a bad driver, as Samstoned said. But I do I reinstall the driver? I don't even know which driver.


     
  9. Spike

    Spike TS Evangelist Posts: 2,168

    set it as static, ensure that "default gateway" is set to your routers IP address, and ping your router. If it fails, lower all firewalls and try again.

    If it still fails, run IPconfig /all in a cmd window, right-click the window and select all, click on the window again so that the highlighting dissapears , and the contents of the window will be copied to the clipboard. Paste them into a text file, and post it here.

    Remember to blank out your MAC addresses.
     
  10. jobeard

    jobeard TS Ambassador Posts: 9,334   +622

    The issue is the DNS settings.
    If you use STATIC cfg, then you must set
    the mask
    the ip address
    the gateway
    and the DNS​
    manually :-(

    ipconfig /all
    will show you this is not simple nor easily quessed -- which is why success
    is much easier with DHCP


    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.1.102
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 205.152.132.235
    205.152.37.254
    10.1.10.1


    I would find my router address (eg the gateway above: 192.162.1.1)
    and use it as the DNS address. This assumes your router can forward requests
    to the ISP (it sure better! )


    the following will demonstate pinging google.com
    $ ping google.com

    Pinging google.com [72.14.207.99] with 32 bytes of

    Reply from 72.14.207.99: bytes=32 time=62ms TTL=235
    Reply from 72.14.207.99: bytes=32 time=61ms TTL=235
    Reply from 72.14.207.99: bytes=32 time=61ms TTL=235
    Reply from 72.14.207.99: bytes=32 time=61ms TTL=235

    Ping statistics for 72.14.207.99:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% l
    Approximate round trip times in milli-seconds:
    Minimum = 61ms, Maximum = 62ms, Average = 61ms​
    you should first PING 72.14.207.99 and see something very much like this.
    using the address (rather than the name) avoids the DNS LOOKUP and
    proves connectivity from your system, thru your LAN and ISP all the way to
    a real websystem.

    when you can ping google.com, it's all running correctly, including DNS lookup :)
     
  11. chow1012

    chow1012 TS Rookie Topic Starter Posts: 17

    If I set the IP to static, I could ping the router. Here are the outputs of ipconfig /all with static and dynamic IP.

    Static IP
    ---------
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.0.102
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.0.1
    DNS Servers . . . . . . . . . . . : 192.168.0.1

    Dynamic IP
    ----------
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IP Address. . . : 169.254.50.11
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :
     
  12. Spike

    Spike TS Evangelist Posts: 2,168

    Either DHCP on the router isn't turned on, your firewall is blocking the DCHP network traffic, or DHCP services aren't running on XP

    As for the ping router but no pinging google on a static setup...

    try setting the computers IP to an adress between 192.168.0.1 and 192.168.0.99,
    like 192.168.0.2 for example.

    The link is for w2k, but the IP settup applies to XP just the same.
     
  13. chow1012

    chow1012 TS Rookie Topic Starter Posts: 17

    1. DHCP on router isn't turned on. This couldn't be the case because it worked with my other partition.
    2. Firewall blocking DHCP traffic. I have tried to disable the firewall completely and the result was the same.
    3. DHCP services aren't running on XP. How to confirm this and how to make it run?

    I have tried setting IP to 192.168.0.2 and it seemed to work. At least I was able to ping 72.14.207.99, 64.233.187.99 (I got this google address with my other partition) but I couldn't ping google.com. Does that mean my DNS is not working? I have set the DNS server address to my router address 192.168.0.1
     
  14. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    conflict between systems
    on one hand with static you don't want dhcp on at router
    but the dynamic setup needs the dhcp to give it a address
    I would change settings in router to 192.168.1.1
    your default gateway should be 192.168.1.1
    not sure why you need the other system to be dynamic ,but there is maybe where the cause is
    you can try to enable dhcp in router it may not cause any problems with the static config
    maybe force the ip address's in the dhcp tables
    dns servers should not be
     
  15. Spike

    Spike TS Evangelist Posts: 2,168

    Try entering one of your external dns addresses (from your ISP - either find them from the router or from your ISP/ISP's documentation) into the DNS section instead of your Routers address. Try pinging google.com from there.

    seems I didn't post the link last time - Doh! http://support.dlink.com/faq/view.a...evC / DI-624S / DI-774 / DI-774_revB / DI-784

    The Dlink FAQ specified LAN IP range to be 192.168.0.1 - 192.168.0.99, and gives the routers default address as 192.168.0.1, though I must admiot, I have known one dlink router to use the 1.1 address as default. Default gateway doesn't have to be 1.1, nor 0.1 for that matter. It just depends on what the default gateways address is and makes little difference to the best of my knowledge.

    Also, 192.168.0.1 (ie, the router IP) is a perfectly legitimate address, provided that the router is actually acting as a DNS proxy (mine does, and routers don't get much cheaper than mine! lol)
     
  16. jobeard

    jobeard TS Ambassador Posts: 9,334   +622

    various vendors default to 192.168.0.1 or 192.168.1.1.
    most allow ANY address to be specified
    as the LAN side is most frequently in the private, non-routed range
    10.0.0.0 - 10.255.255.255
    172.16.0.0 - 172.31.255.255
    192.168.0.0 - 192.168.255.255​
    the 'standard' address for routers is the x.x.x.1 slot
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...