TechSpot

Problem with Sim City 4 + Windows 7

By sedriskell
Nov 3, 2009
  1. I'm honestly not sure if it is Windows 7 that is the problem, because the game was running fine until last night.

    Anyways, when I start the game an error box pops up that says something to the effect of "Can not initialize direct draw." I click OK, which is the only option, and it continues into the startup process. Now, all was fine and dandy until last night, when 75% through the startup it just simply closed. No warning, no error box, it just closes.

    I've tried unstalling and reinstalling it multiple times and it hasn't worked. I also installed it to my external hardrive, but got the same result. I went through and deleted all my plugins and addons for the game, thinking they were just making it spazz out, that apparently was not the case.

    So, if anyone has an words of advice, I would really appreciate it.
     
  2. Kibaruk

    Kibaruk TechSpot Paladin Posts: 1,337   +103

    If it is a direct draw issue it has something to do with the video drivers or the direct x itself, have you tried running it in compatibility mode?
     
  3. sedriskell

    sedriskell TS Rookie Topic Starter

    I have tried running it in compatibility mode but I could be doing it incorrectly, how would you suggest doing it? The direct x problem also sounds plausible. I did have a few problems with it when I first installed 7. Could you explain a bit about the direct x problem possibility?
     
  4. Kibaruk

    Kibaruk TechSpot Paladin Posts: 1,337   +103

    I played it out of the box on my netbook running W7 Professional, try updating your video card drivers and/or reinstalling direct X, if that doesn't work all I can suggest you is to google for "simcity 4 windows 7 issues" or go to maxis forums.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.