TechSpot

problem with updating drivers...

By ceeto
Feb 25, 2007
  1. hey guys, first off im quite a computer-technical n00b :p my first post aswell im just wondering if anyone can help me...
    i play everquest 2 and recently iv been crashing after just a minute or so in game, the screen will completly lock up and i cant tab out or anything..then it just goes black...so i think its the drivers, but when i download the latest drivers from omega or ati website, i go to install them and my whole machine just crashes, with both installations. it has happened before bout a year or so back and i installed the new drivers and everythin worked fine so i just dont know what to do.
    my computer isnt that good but its not bad, my graphics card is quite old though just radeon x550
    if anyone could help me i would GREATLY appreicate it, im really getting frustrated lol :)

    and again...computer noob, so patronise me.. :D
     
  2. dopefisher

    dopefisher TS Rookie Posts: 444

    Hi and welcome to Techspot. Try this: uninstall the drivers completely. then go into your hard drive and delete the ati folder and all the files. next go here and download driver cleaner pro and install it. http://downloads.guru3d.com/download.php?det=745 run all the ati cleaners. then, reboot your PC. after reboot, let windows load, then reboot AGAIN. after next reboot, reinstall all the drivers you need.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...