Problem with USB

By rohit9119
Mar 25, 2008
Topic Status:
Not open for further replies.
  1. Hi All,
    I am using P-IV, 2.3GHz, 256MB RAM, 80GB HDD with Windows XP Professional SP2.
    All the four USBs are not working. When i connect any USB device with USB then power is coming but windows is not detecting it. ( As i connect PenDrive to my USB, light appears in pendrive but windows doesnt detect it. Same case with modem and same case with web cam). I have updated the drives of USB from Device Manager. Please HELP as i am not able to connect to internet at my home.
    Very URGENT

    Thanks
    RJ
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Is USB enabled in Bios?
    Are the drivers updated from your M/b support page?
    Have you tried removing all USB devices from Device Manager, and restart your computer?
    Are there any programs installed (USB lock) that could be effecting it?
    Have you tried other USB ports (and innitially removed all ext. USB, just plugging in one)?
    Has this just happened since doing what ?

    For more help and support with your USB issue:
    Please put your System Specs in your Profile

    If you have a proprietory computer like Dell; HP; Acer etc, please manually write this in the mobo field (ie Dell Dimension 3100 - as an example)
  3. jobeard

    jobeard TS Ambassador Posts: 13,286   +281

    see this USB Power issue;

    If the device requires too much current, it will be shutdown by the system.
  4. ZenMatrix

    ZenMatrix Newcomer, in training Posts: 21

    also you can go to the device manager and reinstall all of the root hubs as those get corrupted alot make sure you goto view and show hidden devices to get rid of any corrupted ones
  5. rohit9119

    rohit9119 Newcomer, in training Topic Starter

    Hi Kimsland,
    Thanks for helo but none of your suggestions helped me.
    I am stuck with my work.
    1) Yes USB is enabled in BIOS
    2) Yes i have updated through motherboard CD.
    3) I have removed all the USB devices from Device Manager but same condition.
    4) I have formatted the system so no programs installed.
    5) This all happened after i had installed Windows XP again, but 3-4 times earlier also i had installed XP and no problem came.


    PLEASE EVERYONE HELP MEEEE.
  6. rohit9119

    rohit9119 Newcomer, in training Topic Starter

    Reinstalling the USB hubd again didnt help
  7. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    So are you saying the hub is causing this?
    Did you read Jobeard's link about ampage, and voltage levels?

    If you plug directly into each USB (before loading the USB hub), is all ok?

    Have you confirmed the bios version is the latest?

    Is it possible that one of your USB devices (including the hub; mouse) may be faulty?

    Have you run optimized defaults in CMOS (actually even M/b jumper reset)

    There's some more !
  8. ZenMatrix

    ZenMatrix Newcomer, in training Posts: 21

    based on what you said I would say the usb controller or the ports are bad at this point its not a xp problem but would try resetting bios defaults and try a bios update
  9. rohit9119

    rohit9119 Newcomer, in training Topic Starter

    1.) i have set the bios settings to default, but same thing there is power in USB port and device like pendrive, webcam are not detecting.
    2.) how do i update bios settings?
  10. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Replying to your last questions (only)

    My first post to you would have helped you here, (but oh well)

    1. You need to reset the bios jumper on the M/b
    2. You need the updated bios firmware using your bios update tool

    To do both these things, you need to download your manual
  11. rohit9119

    rohit9119 Newcomer, in training Topic Starter

    hi kimsland,
    cud u tel me which manual and how do i know which motherboad is mine computer
     
  12. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Please refer to my first post to you (3)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.