Problems launching WoW

By Posion197
Mar 17, 2008
  1. Whenever i try to start-up WoW it says: world of warcraft was unable to start-up your 3d accelereation. please make sure direct x 9.0c is working and your video-card is up-to-date.

    i have direct x9.0c, but i dont know how to update my video card, i have played WoW on this cpu before so i know its not the CPU, it's perfectly fine for WoW, will someone help me please
  2. Posion197

    Posion197 TS Rookie Topic Starter

    can anyone help me?
  3. icebox17

    icebox17 TS Rookie

    have the same problem

    i have the problem with launching WOW
    whenever i click the icon to play my monitor will shut down or hybernate-when i close the WOW (Esc) windows or my desktop will load
    -i already checked my directx 9.0c
    -used 2WOW installer (original)
    -set bios to default
    -refresh rate already tried 60hertz to 75herts
    -meet all the requirement
    -i can play C and C -generals zero hour and reborn with no problem at all
    what else do i need to check just to run the WOW

    extra info
    when my monitor hybernate i can still hear the sounds,
    -i can hear that i can click something

    -i already set my resolution to 800x600
    -i launch the game to 640x420resolution still the same problem

  4. Nexevo

    Nexevo TS Rookie Posts: 16

    If you prvide us with your video card brand and model we should be able to point you in the right direction for the latest drivers.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...