TechSpot

Problems with 2 Networked PCs sharing Broadband

By volume3k
Jan 8, 2005
  1. Ok I just networked my Laptop up to my PC using a crossover cable with the idea that the PC is going to be connecting to the internet through my Cable connection (USB) and the laptop will the share off it via the crossover cable.

    The problem is that when I made the connection it states, "Limited or no connectivity" on the LAN connection icon. However I was able to share the Hard drives and printers etc but not the internet.

    Now the strangest thing has happened because when I went to unplugg the Crossover cable and revert back to my old PC to ADSL Modem I now cant even use the internet!! however I can with the laptop?

    My PC is running WinXP SP2 and the Laptop is running Windows XP without SP2. I tried turning off the firewall thinking that might of been it but nothing

    Any ideas?
     
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    did you enable internet connection sharing?

    Did you configure any fixed IP addresses (your ISP might want dynamically assigned IP)?

    Have you rebooted the ASDL modem?
     
  3. volume3k

    volume3k TS Rookie Topic Starter

    Yes I enabled internet connection sharing and rebooted the ADSL Modem, as for configuring the fixed IP Address I am not sure how to do that...
     
  4. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    If you don't know how, then you didn't do it, I guess. OK, so its not that.

    Turn internet connection sharing off on any place you enabled it, switch everything off, check connections, back on again.
     
  5. volume3k

    volume3k TS Rookie Topic Starter

    I just turned off internet sharing on my desktop and the internet works again for it. Why is it disabling internet when I try and share it?

    still getting the limited or no connectivity though when internet sharing is disabled and the 2 are hooked up
     
  6. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    Its just getting confused a bit, that's all you have to know for now.

    OK, try this:

    -Confirm that PC can connect to internet without laptop connected.

    -If your firewall is zonealarm, make the network that is NOT the ASDL (i.e. the network card you are using to connect to laptop) and make it trusted. turn ALL firewalling stuff OFF for trusted networks.

    -For testing purposes right now, though, TURN FIREWALL OFF ALTOGETHER.

    -Connect laptop (via crossover cable)

    -Go into Network Connections in Control panel on PC, go into properties for the Internet Connection ASDL, and share it.

    -Go into a command prompt on PC

    type:

    ipconfig

    you should have 2 IP addresses, one is ASDL IP assigned by your ISP, the other is 192.168.0.1

    -reboot laptop

    -go into command prompt on laptop

    type:

    ipconfig

    your IP should be something like 192.168.0.x where x is 2 to 254 (I think!)

    type:

    ping 192.168.0.1

    you should get a reply 4 times
     
  7. volume3k

    volume3k TS Rookie Topic Starter

    Thanks for the help works great now!
     
  8. dacarthy

    dacarthy TS Rookie

    OK, I have 2 computers that are connected via a crossover network cable. One feeds off the bandwidth that the "master" computer has. Does anyone know how to stop the master computer effectively "hogging" the internet connection and have a perfect split connection between the two??
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...