Problems With K7n2 Delta2 Plat

By platinum_cloud
Jul 23, 2005
  1. I recently bought a new motherboard. it worked fine for a while, tried to install all my motherboard drivers then it wouldn't boot up. it either:

    1. complains of a CMOS ERROR: keyboard not present or keyboard error

    insert system disk then press enter [no keyboard so cant press enter :( ]

    2. doesn't do anything

    3. starts to POST but stops when it gets to the floppy drive then it says at bottom of screen CMOS ERROR then something about the floppy drive.

    There is a fourth error but that only happens when i don't have the floppy drive connected, then it complains of no floppy drive and an alarm sounds.

    This is starting to piss me off: changed CMOS battery, reset CMOS millions of times using the jumper and still doesn't work.

    I can't get onto BIOS as the keyboard doesn't work no matter what.

    tried the keyboard and floppy drives on other computers and they work fine.

    Is my motherboard damaged beyond repair (no other way but to get a new one) or is there a way to fix this? is it the CMOS?

    i really need help!
  2. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966

    Hello! Welcome to TechSpot

    Need all your system info, it'll help us help you.
    Sounds like ps2 port may have trouble.
    Maybe try adapter from ps2 to usb or even diff keyboard, this would rule
    out them as cause.
    post back!
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    I'd RMA the motherboard, sounds faulty.
    be careful with static also.
  4. platinum_cloud

    platinum_cloud TS Rookie Topic Starter

    MSI K7N2 Delta2 Platinum Motherboard
    Athlon XP 3200
    1GB DDR PC3200 RAM
    ATI Radeon 9700 Pro 128MB

    Seems like it is the PS2 Port. Tried a few keyboards. Does this mean I'll need a new motherboard?
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    looks like it.
  6. platinum_cloud

    platinum_cloud TS Rookie Topic Starter

    got a new motherboard and still no luck. Will have to take it to a shop 2moro 2 get it sorted. hopefully it can get fixed
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...