TechSpot

Problems with Radeon 7000/VE and loading Opengl

By Johnny_Five
Dec 20, 2004
  1. Hi everyone,

    I am going slightly crazy trying to get opengl to work with my video card the Radeon 7000. I am trying to play Jedi Academy based on the Quake 3 engine I believe. I have downloaded every ATI catalyst drivers ever made but none of them seem to help my opengl problem.

    Keeps saying failed to initialize.


    JA: v1.0.0.0 win-x86 Jul 22 2003
    Initialising zone memory .....
    ----- FS_Startup -----
    Current search path:
    C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets2.pk3 (62 files)
    C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets1.pk3 (8320 files)
    C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets0.pk3 (15346 files)
    C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData/base

    ----------------------
    23728 files in pk3 files
    execing default.cfg
    couldn't exec autoexec.cfg
    ...detecting CPU, found Intel Pentium III

    ------- Input Initialization -------
    Skipping check for DirectInput
    Joystick is not active.
    ------------------------------------
    ----- Client Initialization -----
    ----- Initializing Renderer ----
    -------------------------------
    ----- Client Initialization Complete -----
    --- Common Initialization Complete ---
    Working directory: C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData
    couldn't exec setlanguage.cfg
    Initializing OpenGL subsystem
    ...initializing QGL
    succeeded
    ...setting mode 4: 800 600 FS
    ...using desktop display depth of 16
    ...calling CDS: ok
    ...registered window class
    ...created window@0,0 (800x600)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...failed to find an appropriate PIXELFORMAT
    ...restoring display settings
    ...WARNING: could not set the given mode (4)
    ...setting mode 3: 640 480 FS
    ...using colorsbits of 16
    ...calling CDS: ok
    ...created window@0,0 (640x480)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...failed to find an appropriate PIXELFORMAT
    ...restoring display settings
    ...WARNING: could not set the given mode (3)
    ...shutting down QGL
    ...unloading OpenGL DLL
    ----- CL_Shutdown -----
    -----------------------
    GLW_StartOpenGL() - could not load OpenGL subsystem

    Every version of the driver has come up with the same error. Lucasarts the maker of the game say this card was tested with this game.

    Any ideas??
    Thanks
     
  2. digger15

    digger15 TS Rookie

    Open GL

    Hey Johnny five. I'm having the same problem only I've got an inbuilt graphics card on the mother board. I've done the compatibility test and it too says Jedi Academy will play fine.

    My only solution is to go to their website and ask them!

    I think I'm going to have to buy myself a external card so I can play the game. Also, when I double click on the icon it asks for cd 1 to be inserted when I do this, it wont play it. Anyway e mail me if you've found a way arouond and vice versa.

    Cheers
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...