TechSpot

Problems with remote Desktop Connection.

By Youngblood
Aug 17, 2006
Topic Status:
Not open for further replies.
  1. Hi. My name is Neil and I have a problem with Remote Desktop Connection that has not only stumped my ISP and myself, but, has also stumped D-Link, the manufacturer of my router.

    I will be in shock and awe if someone is able to find an answer to my problem.

    For approximately 7 months, I've been connecting to my desktop from work and from a friend's computer via Remote Desktop Connection with my router connected to my computer at home with zero problems until recently. The computer at work and my friend's computer are both running Windows XP Pro. When I first connected the router to my computer at home, I read the instructions on how to configure Remote Desktop Connection. I opened port 3389 as instructed, enabled all protocols and from there, I went on to use Remote Desktop Connection with zero problems...until about a month ago. I now, all of a sudden, can not connect to my desktop from any computer. I can, however, ping my IP and I get a response every time (via ping and tracert in a DOS shell). The Remote Desktop Connection client just times out every time now. I've had a new router sent to me from D-Link via the warranty and I still can not connect to my desktop. If, HOWEVER, I disconnect the router from my computer, I can then connect to my desktop via Remote Desktop Connection (with the WAN IP address being different). Right around the time I all of a sudden couldn't connect to my desktop, I noticed that my WAN IP address for my desktop was DIFFERENT with the router connected/disconnected. For the first seven months of having the inital router, the WAN IP address for my desktop was the same with the router connected or disconnected. I've tried using either WAN IP address to connect to my desktop, but, to no avail. When I told D-Link this, they immediately assumed that I needed to establish a static IP address. I disagreed highly with them but they insisted. I contacted my ISP and told them this and they laughed, but, they couldn't explain why my WAN IP address was now all of a sudden different with my router connected/disconnected other than to say that my IP address was dynamic and that it does change. The two WAN IP addresses I get are always the same when the the router is connected/disconnected. I've always been fully aware that my IP is dynamic and I understand that it can change and I always confirm what my WAN IP address is before I make an attempt to connect to my desktop. I even tired configuring a static LAN IP address on Windows XP with the router connected and nope...still can't connect to my destop from any computer.

    With my recent conversation to D-Link, I sensed a great degree of hopelessness. The help desk guy on the phone didn't seem to know what information to offer me because I've CHECKED EVERYTHING A MILLION TIMES (router configuration, Windows XP firewall settings, Remote Desktop Connection Settings, etc.) and I've done all the router resets, reboots, firmware check, etc. In a nutshell, for 7 months, I was able to connect to my desktop via Remote Desktop Connection with no hassles, until, one day, all of a sudden, I couldn't connect. Within that 7 months, I made NO CHANGES to the router. EVEN WITH THE DMZ SETTING ACTIVATED ON THE ROUTER, I STILL CAN NOT CONNECT TO MY DESKTOP! As I understand, activating "DMZ opens all the ports", according to D-Link. Every other program that I use (MSN, ICUII, etc.) are all configured on the router and they seem to work FINE.

    After trying everything known to D-Link, my ISP and myself, I still cannot connect to my destop from any computer as long as my router is connected. I also can't use Remote Web Desktop Connection either. I also can't use any other port to connect to my desktop (eg. 70.71.61.52:80). It would be easy to just disconnect the router and not use it and then blamo...my problem would be solved, but, the whole reason why I got the router was so I could close unsafe ports and add some more security for my computer as I was being hacked just prior the the purchase of my router. I'm tempted to just say "screw it" and buy Zone Alarm and smash the router with a sledge hammer. The router that I'm using is not wireless and I only have one computer at home.

    Anyone have any clues? I'm about to throw the router out the window. Clearly, the connection problem I'm having HAS to be something to do the the router.

    Maybe someone out there has an answer for me? Maybe not. Any suggestions/advice would be GREATLY appreciated.

    Your new friend,

    Neil
  2. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    have you tried upnp enable let it config the router then disable it
    try diff higher port number Ports 5631 (TCP) and 5632 (UDP) the higher the better
    how about disable dhcp in router
    look to outpost firewall before ZA
    know anyone you can bum a diff make router from
    since only one machine try disable nat and enter the ip address static
    I have known isp's to mess with some port numbers used for p2p
    they will not tell you that they do
    do ipconfig /flushdns cmd line
    ther try to find out whet address you got from isp
  3. davids

    davids Newcomer, in training Posts: 177

    Youngblood Can you run through how you have everything setup so its clear:
    From what you've said so far, you have a router, that has a dynamic IP address on its wan port.

    then you have how many computers in your LAN? And how do they get IP addresses? are they assigned privatly by the router?
  4. Youngblood

    Youngblood Newcomer, in training Topic Starter

    hey davids:

    I have one computer in my network. that computer has one LAN IP address (obviously, the router has an IP address as well). The connection to the internet is as follows:

    from the wall to the cable modem, from the cable modem to the router and then from the router to the computer.

    the LAN IP address is assigned by the router.
  5. Youngblood

    Youngblood Newcomer, in training Topic Starter


    Hey Samstoned:
    how do I try upnp? what do you mean by "look to outpost firewall before ZA"?
    Thanks for your time.
  6. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    router manual to set the upnp up
    I don't know if your remote software uses upnp
    most P2P programs do
    browse the settings in router may find it if you can't get a manual

    outpost is software firewall for me better than ZoneAlarm
    when change back and forth for test you have to flush dns
    run cmd type (ipconfig /flushdns)
    check WAN ip from router call your isp ask them if it a good number
    then as I suggested use a high port number like 28,222
    if you can add several both tcp udp

    if this works make sure you disable the upnp after
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.