Processor fried...? :(

By shanejohnson02
Apr 22, 2006
  1. I recently bought a barebones kit from TigerDirect and installed everything according to the manuals with it. I was especially careful with the processor, making sure I didn't bend any contacts or anything. I even double-checked later and it was indeed properly seated in the socket. All the jumpers and cables are hooked up correctly, as far as I can tell.

    Last night, I would turn it on and the fans would spin around once and then quit. The LED would light up. Now, nothing turns on at all. I fear there is something wrong somewhere and it may possibly be the processor.
    The case was damaged when I got it (it had been dropped and the top right corner on the rear was dinged pretty badly). I considered calling Tiger right then, but decided I should try to se if it works first to determine if it was worth the effort.

    Is there anything I'm doing wrong or any possible solution short of sending it back to tiger for an exchange/refund?
  2. Coolmatt

    Coolmatt TS Rookie Posts: 66

    Sounds to me like you shorted the Mobo. Did you install spacers when you placed it into your case? Also was the dent interfering with the mobo?
  3. KingCody

    KingCody TS Evangelist Posts: 992   +8

    if you recieved your case damaged, then get a new one.

    as far as your other hardware is concerned, you should always table test a system before installing it into a case. connect it up on a non-static surface (i.e. a kitchen table, not on a bed.. lol) and see if it all works there.

    if it does, then verify that you put the motherboard standoffs only where there is a mounting hole on the motherboard. chanes are your kit came with more standoffs then you actually need, so be sure that you only use what the mobo needs and you place them in the correct holes. the motherboard mounting holes will have a metal ring around them, if it doesn't, then do not put ametal standoff and screw there (if you have them, you can use a plastic standoff instead)
  4. 0009

    0009 TS Rookie

    hey could you link me to a picture of spacers...are they the golden screws that screw into the case then you put the mobo on top of it then you screw it down...?

    i put the washer in then the golden screws than the mobo than screw it all down. i hope thats the right way..
  5. Coolmatt

    Coolmatt TS Rookie Posts: 66

    It's actually Screws -> Washers -> Mobo but still as long as I know the Mobo isn't touching anything conductive, it's just fine. The problem still sounds to me as though your fried the Mobo but will it even turn on after that initial occurence?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...