Radeon HD 3650 driver installation problems

By MysterioMask
Aug 4, 2011
Post New Reply
  1. I had to recently install a new hard drive into a computer. The graphics card is a Radeon HD 3650 and I have been looking for drivers for it. Since the person who originally bought the card threw the box with the disc away i had to download the drivers and installation from online. I downloaded all the drivers and catalyst and when i go to install the products it appears to install and even says finished but when i look it doesnt seem to actually install anything at all even on a restart. The catalyst control center doesnt show up on my start menu and the graphics card still appears as uninstalled in the device manager. Does anyone happen to know what the problem is or how to fix it?
  2. Leeky

    Leeky TechSpot Evangelist Posts: 4,378   +97

    Where did you download the drivers from?

    If you haven't, get them from www.amd.com or www.amd.co.uk

    Be sure to select express install during installation.

    But before you try it again, remove the previous drivers.
  3. MysterioMask

    MysterioMask TechSpot Enthusiast Topic Starter Posts: 180

    Yep got them direct from amd. and selected express install. contacted amd about it in an email but they havent replied yet, and its been a few days
  4. Leeky

    Leeky TechSpot Evangelist Posts: 4,378   +97

    Try running driversweeper on it and removing the GPU drivers. Delete the old downloads of the drivers, and then reboot, and download new drivers, and try to install again.
  5. MysterioMask

    MysterioMask TechSpot Enthusiast Topic Starter Posts: 180

    either im being dumb or i cant find the actual download for drivesweeper on the page, i clicked one that says download now and it takes me to another page with alot of downloads for stuff i dont want and i cant find the actual drive sweeper download
  6. MysterioMask

    MysterioMask TechSpot Enthusiast Topic Starter Posts: 180

    Downloaded it from another place let you know how it works out
  7. MysterioMask

    MysterioMask TechSpot Enthusiast Topic Starter Posts: 180

    Tried that and reinstalled, still do not see catalyst control center installed anywhere and the webpages still have that jerky motion when scrolling down them. and device manager still says uninstalled


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.