TechSpot

Realtek HD Audio Manager Problem

By Sai
Jan 14, 2010
Topic Status:
Not open for further replies.
  1. Hi


    I am having a problem setting up my new audio connections. I have a simple 2 speaker desktop system that also comes with a sub. The two speakers have jack connections to the sub unit and then the sub has a green cable connection that use to always hang out in the green port in the back panel of my computer.

    But i recently bought a Razer Lycosa keyboard and that comes with a headphone and mic port on the keyboard itself.

    So i connected the green and pink cables from the keyboard to the green and pink connections on my back panel (headphone and mic) and plugged in my green cable from the sub to the black port of the back panel.

    So in the Realtek HD audio manager 3 ports are used. The green port is set to headhpones (for the keyboard), the pink port is set to mic (for the keyboard) and the black port is set to front speakers.


    The front speakers and sub work perfectly fine, they play audio as always. The headphone jack on the keyboard also plays audio when i plug my headphones into them, however...... when i plug my headphones into the keyboard it doesn't disable the desktop speakers, they both play at the same time.


    I've been in contact with Razer to see if there are keyboard settings that are meant to resolve this but there is no option in the keyboard for any of this. Razer say this is an audio driver issue...

    So is there any way that i can set the Realtek manager to understand when headphones are being plugged into the keyboard? Or is there a way i can manually disable the desktop speakers when i plug in my headphones?
  2. dustin_ds3000

    dustin_ds3000 TechSpot Chancellor Posts: 1,128

    its not a driver problem. if you tell me what version of windows your using i can help you more. here is a simply solution, open Realtek HD Audio Manager right click on black port on the right and go to Audio Device Settings then from there move the slider on the top to mute the desktop speakers when you want the muted
  3. Sai

    Sai Newcomer, in training Topic Starter Posts: 41


    Thanks for the reply.

    Im using windows 7 (64 bit).

    I tried going into Audio device settings but nothing opens, i have the Realtek HD audio manager installed through my motherboards software installation disk and its version 6.0.1.5780. I downloaded a newer version of the software from Realtek's site but im not sure it installed properly or something as its still showing the older driver version :(
  4. dustin_ds3000

    dustin_ds3000 TechSpot Chancellor Posts: 1,128

    ok im trying things out, i have Realtek HD Audio and windows 7 so if i find a solution other just unplugging the front speaks i will let you know. you would think windows would see the two devices as two separate devices but it sees it as one
  5. Ultiweap

    Ultiweap TechSpot Enthusiast Posts: 742

    Realtek HD I don't know if it will detect but for Intel I know that it detects it. Try putting the latest driver for it as mine on Intel withtout the latest driver I should change it on windows for it to work. Maybe it is the same for Realtek.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.