Reboot and select proper boot device..

By Coop315
Apr 21, 2011
Post New Reply
  1. My storage configuration is set to IDE but it's a SATA drive and there is no option for SATA drives. I am not very knowledgable about how my computer was setup as I wasn't the one who did it.

    Boot device priority is 1. Hdd hard drive
    2. cd-rom
    3. Floppy drive (i don't have one installed and doesn't come up in the bios, but when I reboot and press f8 to select boot drive it appears first on the list and. I still get the error if I select my HDD).

    So here's what's going down, a couple of days ago my computer blue screened and I started it gave me a primary hard drive failure on startup and when I pressed f1 to continue it came up with reboot and select proper boot device. So I bought a new hard drive and it doesn't give me any hard drive errors but still gives me the same boot error and when I had put my windows 7 disc in and made my cd drive the main boot device (which can play DVDs as well) I still got the same error. So I used my brothers computer and installed windows on the hard drive which installed perfectly with no issues but when I hook it back into the computer I get the same "Reboot and select..." error. I am using a SATA HDD.
  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,889

    I am wondering if you might need a Bios update but first try removing the CMOS battery for 20 minutes and then put it back in, this will reset the Bios to default. Check the battery with a voltmeter and if below 2.5V replace it with a new one.

    Check the connections on your SATA HD and make sure the connection on the mobo is securely in place. Go into the Bios and set the CD to 1st in the boot order and then try again to boot from the windows 7 disc.

    You need not worry about the non existent floppy drive appearing in the boot order, this is normal.

    In your Bios you need to check the Serial-ATA controller is turned on. Difficult to give precise instruction as all Bios set ups are different but it should be fairly similar to this.

    Integrated Peripherals > IDE function set up > (check here that Raid Enable is Disabled) > Serial-ATA controller enabled.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...