TechSpot

Reboots, problems with irq and bios

By xLokix
Mar 24, 2009
Topic Status:
Not open for further replies.
  1. Hi all , Im as of late , Having problems with my machine once again , i cant figure it out . the screen usually tweaks out and i get a horrible noise from my speakers , complete system freeze , along with random reboots , just started the other day , im getting irq errors and disk / atapi errors in event viewer . attached are the minidumps , Any info would help me out along , Thank you all very much.
     
  2. Route44

    Route44 TechSpot Ambassador Posts: 12,155   +34

    All three errors are 0x000000EA: THREAD_STUCK_IN_DEVICE_DRIVER

    A device driver problem has caused the system to pause indefinitely (hang). Typically, this is caused by a display driver waiting for the video hardware to enter an idle state. This might indicate a hardware problem with the video adapter, or a faulty video driver.


    All three cite ati2cqag.dll which is an ATI Central Memory Manager / Queue Server Module. We have seen quite a few people have issues with this driver.

    Try the following and tell us if it resolves the problem:

    1. Download Driver Cleaner Pro (free version) to your desktop screen and install.

    2. Download the latest diver(s) for your video card but don't install them.

    3. Uninstall your video card drivers and reboot your PC into Safe Mode. Run Driver Cleaner Pro. If it doesn't find any video card drivers that is quite okay.

    4. Reboot and install new video card drivers.
     
  3. xLokix

    xLokix TS Rookie Topic Starter Posts: 48

    ...

    Removed all drivers and registry keys in safe mode , reinstalled drivers etc. Seemed to work for a while , went to the store , came back and screen was glitched and system locked up again. Im assuming i have a bad video card then ? because when i turned it off and started it back up video wouldnt come up on the bios until about 4 more power downs. New dump attached just incase . Same Driver file?
     
  4. Route44

    Route44 TechSpot Ambassador Posts: 12,155   +34

    Same error and same driver. I suggest going to the Nvidia forums and search for this driver and your OS. I know there should be a lot concerning this issue.
     
  5. xLokix

    xLokix TS Rookie Topic Starter Posts: 48

    I have an ATI card. I would assume its not driver related if its locking up or the gfx card isnt powering on in CMOS. Thanks for all your help i appreciate it.
     
  6. Route44

    Route44 TechSpot Ambassador Posts: 12,155   +34


    DUH ME! Why I wrote Nvidia I don't have clue. :confused: :eek: How about this: Go to the ATI forums and see what they have to say.

    By the way, does your BIOS recognize the card?
     
  7. xLokix

    xLokix TS Rookie Topic Starter Posts: 48

    ...

    im guessing so , it works fine for a little while like i said , i can play battlefield 2 and all , seems like it works fine unless i walk away from the computer for a few minutes while im in a game or something, seems pretty random when it does it , and im pretty sure that the bios recognizes it , just when it does freeze , i shut it off , and usually like 4 or 5 trys later my monitor will flick on when i start the machine, One time it showed the bios but started glitching and showing ascii chars and such then went to a blank green screen. but ive been on the pc and played bf2 for a few hours tonight , watched some videos and such and hasnt froze yet. boggles my mind
     
  8. Route44

    Route44 TechSpot Ambassador Posts: 12,155   +34

    Lets take this from a different angle. Have you scanned for infections recently? If not, do so.

    Also, do you have your PC set for hibernation? Many people experience issues when it transitions from this state to full power on.
     
  9. xLokix

    xLokix TS Rookie Topic Starter Posts: 48

    .

    Yes PC is clean and how would infections of spyware or virus affect my Cmos lol .
    Im just going to assume my videocard is dieing . ill grab a new one soon and let you know if the problem is resolved.
     
  10. xLokix

    xLokix TS Rookie Topic Starter Posts: 48

    .

    Oh and sorry , no i do not use any sort of power saving feature , my pc is on 24/7
     
  11. xLokix

    xLokix TS Rookie Topic Starter Posts: 48

    Think my motherboard is going bad ? Assuming since this problem started im having disk errors atapi errors and acpi errors related to IRQ etc now ?
     
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.