Recovered video from SD Card won't play

By blablabla489
Jan 6, 2007
Topic Status:
Not open for further replies.
  1. I accidently deleted my whole SD card and then used various programs to recover the data. Almost everything was recovered but, one 128MB video was recovered but will not play, I get the error msg <<Windows Media Player cannot play the file. The Player might not support the file type or might not support the codec that was used to compress the file.>> Other videos recovered played fine but I can't get this one to play. Any suggestions on what I can do or where I could take the data to fix it would be greatly appreciated. Let me know if I can provide any other information to assist in the creation of a solution. Thank you in advance.
  2. cfitzarl

    cfitzarl TechSpot Chancellor Posts: 2,520   +9

    Welcome to Techspot :wave: ! Do you know what the file format is (usually listed underneath the name)? If you do know, try and find a codec for it on google or another search engine.
  3. blablabla489

    blablabla489 Newcomer, in training Topic Starter

    cfitzarl, there is no suffix on the file so I do not know the format, it was recorded on a cannon digital camera, does that help? I also just downloaded VideoLan Player and tried playing it through that but that did not work either. Any other sugestions?
    Thanks
  4. Jesse_hz

    Jesse_hz TechSpot Maniac Posts: 638

    1. If you transfer the file to the SD card will it play on the camera? If it doesn't then there is a chance that not the entire file was recovered and you'll need a program to fix the file.

    2. Do you by any chance know what a Hex-editor is? If you do, could you please open the file in one and tell us what the first four characters in the file are? (If they are human readable characters)
  5. cfitzarl

    cfitzarl TechSpot Chancellor Posts: 2,520   +9

    No, not a suffix. It appears below the file name for instance;

    Name
    Format
    size


    That's what I mean.
  6. blablabla489

    blablabla489 Newcomer, in training Topic Starter

    cfitzarl, format says (.avi)

    Jesse_hz, It will not play on the SD card in the camera, what program or type of program should I use to fix this? I downloaded a Hex-editor and this is what it said:
    2E 20 20 20
    but there were numbers in different windows, these were in the main window along with a zillion other numbers in list format, are these the right numbers?
    Thank you.
  7. Jesse_hz

    Jesse_hz TechSpot Maniac Posts: 638

    Well a period and three spaces doesn't tell us much and I just realized that not all formats have their format tag at beginning of the file.

    Instead of posting the four characters at the beginning of the file, could you scroll down untill you can see a group af letters like "GIF98a" or "JFIF" (will be different in your case) and post that here. If you cant see anything like that, then the header is most likely corrupt or it wasn't recovered and that will make identifying the filetype a lot more difficult.

    Without knowing the format of the file there really is no way (none that I know of) to fix it.
  8. blablabla489

    blablabla489 Newcomer, in training Topic Starter

    I didn't see anything like that but I am including some screenshots I captured of the hex-editor so you can see what I'm seeing. I don't think there is anything I should not be posting on the web(like personally identifieable info) in the screenshots but let me know if there is. Thank you.
    View attachment Noname4.bmp

    Here is another screenshot. (only let me do 100KB at a time) Thank you. View attachment Noname7.bmp
  9. Jesse_hz

    Jesse_hz TechSpot Maniac Posts: 638

    Doesn't seem like there is a header in the file then.
    I don't know what I was thinking yesterday. What I should have told you to do was open one of your working files from the same camera and see what format that file was in. Try opening it in WMP and then go to File -> Properties, then post what it says in "video-codec" and "audio-codec".

    Why? Why didn't I immediately think MJPEG when I heard it was from a camera?
  10. blablabla489

    blablabla489 Newcomer, in training Topic Starter

    Jesse_hz,
    O.k. that part was something I could do :) Thanks for taking all your time to respond to my delema!
    Results:
    Audio codec: Morgan Stream Switcher
    Video Codec: LEAD MCMP/MJPEG Decoder
  11. Jesse_hz

    Jesse_hz TechSpot Maniac Posts: 638

    I found this thread on the doom9 forums, that seems to have a lot of info on fixing avi files with MJPEG. You will need the free application VirtualDub.

    If that completely fails, there are a some other applications you can try:
    Video-Fixer
    ASF-AVI-RM-WMV Repair
  12. tweakboy

    tweakboy TechSpot Maniac Posts: 518

    Could be a formate issue,
  13. blablabla489

    blablabla489 Newcomer, in training Topic Starter

    Jesse_hz,
    Thank you sooo much!!! The program "ASF-AVI-RM-WMV Repair" worked beautifully!:bounce: The other programs either did not work or I did not know how to use them, the latter is my guess. The ASF-AVI-RM-WMV Repair had a prompt for a similar file format to compare the repaired file:bounce to so I think that did the trick. I want to thank you again for all the time and effort you put into my mistake, I really appreciate it.:grinthumb
     
  14. Jesse_hz

    Jesse_hz TechSpot Maniac Posts: 638

    I'm glad it worked out for you! :)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.