TechSpot

Registration 'nag' screen for Photoshop CS2

By SamRick
Aug 8, 2013
Post New Reply
  1. Having paid for several versions of Photoshop Elements over the years, I was very pleased to see that Adobe generously offered CS2 for free use in the community. A little 'old-style' certainly (I use CS5 and CS6 at work), but it does all that I need.
    Only problem with it is, though, that every time I run it up, I get the registration 'nag' screen, despite having gone through the process at least twice, and also checked that it appears as a registered product in my Adobe account.
    Can anyone tell me how to disable the 'nag' screen? It only requires another clock of the mouse on startup to stop it, but it's irritating!
  2. Erik

    Erik TechSpot Staff Posts: 292   +10 Staff Member

  3. SamRick

    SamRick TS Rookie Topic Starter

    Oh, yes. I have verified that CS2 is registered on my Adobe account, so you would think that the loop would be closed and stop prompting for registration. Just one more point has occurred to me, though. I prefer to go looking for product information when I want to, rather than be pestered by promotional emails, so I usually decline invitations to accept them, as I did here (I did not check "Yes! I would like Adobe to send me...blah-blah"). Maybe to get Adobe off my back I need to swallow the bitter pill, then unsubscribe later. Maybe that would work? I will try it.
    There doesn't seem to be any way that I can find, to disable the automatic registration on startup - I suppose it's the price that Adobe insist you pay for getting free software.
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,524   +299

    I don't know how to solve your problem, but I got CS2 the same way you did and did not keep the box checked for them to spam me with stuff. My CS2 is nag free. So you didn't make a mistake there.
  5. bobcat

    bobcat TechSpot Paladin Posts: 688   +67

    Have you tried the obvious first measure of uninstalling and re-installing?

    And when you enter the key, make sure there's no space before or after it.
  6. Erik

    Erik TechSpot Staff Posts: 292   +10 Staff Member

  7. DirkC

    DirkC TS Rookie

    There a simple solution to this. Right click on your CS2 icon and choose "run as administrator," then select "do not register." Exit Adobe and the next times you start the program normally, nag screen gone.
  8. SamRick

    SamRick TS Rookie Topic Starter

    Brilliant! This fix worked!
    I wonder if the problem was that I use a Windows account with admin privileges (I worry about this sometimes), but I haven't been running the app 'as administrator' - perhaps this has confused it. Anyway, now having set 'do not register' on the nag screen when run as administrator, CS2 remembers the setting for normal execution.
    Well done! Many thanks.
    SamRick


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.