Removing vsafe from verbatim flash drive

By Technochicken
Sep 18, 2008
  1. I recently purchased a 4gb verbatim flash drive. It came with this application called vsafe, which makes you enter a password to acces your files on the drive. I got sick of doing that, so I backed up the drive and reformated it by right clicking on it, and choosing "format.". This seemed to work, but when I plugged the drive back in a few minutes later, vsafe was back on it, and my same old password worked. Is there any way to completely remove vsafe?
  2. hittman

    hittman TS Rookie

    Admin Tools

    Plug your USB Drive into your computer, then go to:

    Control Panel / Administrative Tools / Computer Management

    Then once in the Computer Management Window look on the left under "Storage" and click the + to expand.

    Find your USB drive on the list to the right.

    If you right click the drive on the list, you'll have several options including the option to format it.

    I've found that sometimes this works better then just right-clicking the drive from the My Computer area as you have more options.

    Hope that helps.
  3. Technochicken

    Technochicken TechSpot Paladin Topic Starter Posts: 729

    Sorry I took so long. I tried that and got the same results as before.
  4. roshann12

    roshann12 TS Rookie

    I had the same problem. I have formatted the disk using Windows formatting tool. I tried all kinds of V-Safe software and they all came up with same error message "Please insert Plug n Go device and run as priveledged user". Finally I found the right version and I was able to log into the drive. If you don't like logging in, then Click on Settings on V-safe software and then click format and assign desired space to public zone. This way you don't need to login.
  5. Technochicken

    Technochicken TechSpot Paladin Topic Starter Posts: 729

    Reformating the vsafe protected part of the drive under the vsafe settings would not work on my computer. It kept saying "formating error" but I tried it on another computer and it worked, so I'm good to go =). It was only realy a problem because vsafe does not work on macs, and that is all we have at my school. Thanks for the help.
  6. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    You need to remove ALL partitions, define ONE partition, and then reformat as FAT32 for multiple system compatibility.
    I know there's a partition size limit for FAT32 but don't recall it at this moment.
    If you hit the limit, then make TWO equal size partitions :)
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...