TechSpot

RM-SW91 screen goes black once it gets to Windows

By terry5880
Jun 26, 2012
Post New Reply
  1. hi all got rm-sw91 I reformatted windows xp done updates etc but then once restarted few times it gets to welcome loading windows screen then screen goes black laptop is still running but no screen .. help please
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    What is a rm-sw91?
     
  3. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 321

    its a laptop mate I never heard of make before to but I found problem I went in safe mode uninstalled some g3 graphics driver and it was ok but soons as got to desktop it said found new hardware then went again so I think I need to delete this driver then it will be ok
     
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I did a search and it turned up nothing related to a computer. No other numbers or names on the laptop?
     
  5. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 321

    na says RM MODEL- IS SW91

    ah I think its called a compal the rm was in the centre just under screen so thought thats what it called lol
     
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    So is it working now?
     
  7. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 321

    yea sort of well I go to device manager and in display its got sis 3 driver and thats stopping it going to desktop when I uninstall and delete that it works fine but then .. while later it reinstalls itself how can I stop this mate
     
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Disable it and don't uninstall it and see if this works
     
  9. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 321

    ok thanks its annoying that it keeps reinstalling itself lol
     
  10. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 321

    I know this is not the thread but got macbook pro now and wont turn on tried different charger but even no light coming on charger when plugged in but works fine on another one
     
  11. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I don't work on many Mac's but I know that because the charger light doesn't come on, the Mac's motherboard or charging circuit is shorted...
     
  12. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 321

    ok thaNKS alot bud
     
  13. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 321

    what could cause the short or how could it be fixed I have put a thread up as I know this not the place but just thought id ask .. mate thanks
     
  14. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Well, you will have to open it up and look at the AC jack and what it is attached to. If it goes directly to the motherboard, you would have to replace the board. The AC charging circuits operate using a lot of current. Current causes heat, and heat destroys electronics
     
  15. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 321

    true thanks bud Tmagic650 techspots no1 :):cool:
     
  16. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    You're welcome :)
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...