router problem!

By e_p_a_k
Sep 5, 2007
Topic Status:
Not open for further replies.
  1. i'm using a DSL connection on my computer. recently i installed a router by just passing the connection from the modem to the router, and then to the two computers. its worked before, i mean i've been able to go online using both computers at the same time, but sometimes it just won't connect. the diagnose function of windows vista just says that there may be a problem with my DNS. i don't know how to work it. i went online now by taking the connection off of the router and plugging it straight into the computer. how do i fix this?? the router didn't come with any software, so i must have missed something in configuring it
  2. tipstir

    tipstir TS Ambassador Posts: 4,596   +79

    Welcome to TechSpot!

    Step1

    What's the make/model of the router?
    Are both PCs running Vista OS?
    Did you give your workgroup a name? bobnet
    Did you give your pc computer names? bobnet001 PC#1 bobnet002 PC#2


    Step2 when you connect both PCs to the router
    Click on start
    Click on run
    Type: cmd / press okay
    Type: ipconfig /all then press enter

    What you should see here is how the PC you're working on is connecting
    to DNS (router managed)
    Is it getting a DHCP (router managed)
    IP 192.xxx.xxx.xxx this would be okay if you see 169.xxx.xxx.xxx then you have a problem with the router communcating with the PC. That needs to be attended right away.

    Each on do in steps press enter after each command wait a few before continuing:

    Try: ipconfig /flushdns
    Try: ipfconfig /release
    Try: ipconfig / renew

    Reboot that PC that is giving a problem or both. If it doesn't work update the firmware by going to the router manufacturer and download the firmware. You might have to reset the router also.
  3. e_p_a_k

    e_p_a_k Newcomer, in training Topic Starter Posts: 31

    nyaaarr..didn't work.:s it showed 192.xxx.xxx.xxx, but after trying the three steps, neither computer works. i know its not the internet connection, because plugging the connection straight into the computer from the modem works, but passing it through the router doesn't. one computer is using windows XP, the other is using vista. just fyi, i can access the shared files on one computer from the other, so i guess i've set up the workgroups properly? the router is an asus rx3041.
  4. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    ya have to assign user name password to router
    forget the dsl software for now don't even try to connect with router and with the software
    the old way I did it use the ppoe setup add user name and pass
    tick keep alive check connection or what ever your router uses to stay online(read manual)
    for now leave dhcp on
    reboot router ,reboot pc ,reboot modem
    newer dsl modems are also routers ,conflict happen with dhcp server
    your router is trying to assign dhcp so is the modem,may need to disable dhcp in router
  5. tipstir

    tipstir TS Ambassador Posts: 4,596   +79

    When you connect to the router did you disable the software for DSL to the modem. And did you reconfigure the router to it can connect to the internet. Think of DSL like a dial-up modem. You must of been using some sort of software as samstoned mentioned above. Also I did check the router you have there is a new firmware update for it, might as well get that it seems to have fixed some bugs in the router firmware.
  6. bradthegreat

    bradthegreat Newcomer, in training Posts: 141

    here's an idea that worked for me...

    plug your computer straight into the DSL and run ipconfig. you should get something like 192.168.0.100 - that is the address that the DSL modem hands out.

    now, plug your router into the DSL and go into the router's configuration. Change the IP range of the router's DHCP to be opposite of the modem's IP, like so:

    if DSL modem is 192.168.0.100, set your router to be 192.168.1.100
    if DSL modem is 192.168.1.100, set your router to be 192.168.0.100

    the important thing is to change the 3rd octave so it is not the same as the DSL modem. save the config, restart the router and see what happens. you shouldn't need to worry about user names or passwords yet...just see if you can connect with both computers to the Internet
  7. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    bradthegreat you say that config worked for you
    lowered the subnets a little

    after you did that what did you set dns for??

    most modems will pull ip from the routers subnet
    like router ip 192.168.1.1 modem should be 192.168.1.100
    I have been told by comcast that there modem picks up that ip from router
    I never tested that.as for 1st posters issue will wait n see
  8. bradthegreat

    bradthegreat Newcomer, in training Posts: 141

    to tell you truth, Sam, I did this at my grandma's this summer and can't remember all the steps that I did. If I remember right, I ran the router setup wizard and it got all of the settings and configs from the modem. I messed around with manually setting it, but ended up just using the wizard. The issue was then that I could connect to the router fine and it was giving me a valid IP, but I couldn't get internet.

    that is were I changed the IP that the router hands out from 192.168.1.100-150 (or whatever) to 192.168.0.100-150. By changing the third octet, the router then knew that I was not part of the modem/Internet connection and thus changed my IP to the correct one so I could get to the Internet. I did not mess with anything else, just the settings of the WAN/LAN. After that, I was able to connect up to three computers to the wireless/LAN without any problems. Hope this makes sense to you.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.