Rpc Server

By mr hezloop
Dec 6, 2005
  1. im using my girlfriends parents computers, the main one is upstairs with the printer connected, the other computer is downstairs.they are both connected together.the problem is im using microsoft streets and trips downstairs because they dont have that program on the computer upstairs and i want to print something off but every time i click print i get the message "the RPC server is unavailable" and it wont print.what do i do to get it to work? thanks to all who help.
  2. patio

    patio TS Maniac Posts: 482

    What OS is on both machines ? ?
    When you say they are connected; How so? ?
    Are they set up on a wireless network or just sharing an internet connection ? ?
    If they are connected via LAN have you enabled file and print sharing ? ?
    If this still hasn't worked have you checked both machines to see if RPC has been dis-abled ? ?

    Providing more info usually produces quicker troubleshooting...

    patio. :cool:
  3. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    This above link might be of some help for you. This is probably related to the RPC service being disabled on one computer... or both.

    You can try

    • Click Start
    • Click Run
    • Type cmd and press [enter]
    • Type net start rpcss and press [enter]
    • Try to do what you were doing again, it should work. If not, repeat this process on the other PC.

    If it works, do the following for both computers
    • Click Start
    • Click Run
    • Type services.msc and press [enter]
    • Double click on Remote Procedure Call (RPC)
    • Click on the pull down menu and choose "Automatic" instead of disabled or manual
    • Click "OK"
    • Restart the computer
  4. mr hezloop

    mr hezloop TS Rookie Topic Starter

    both computers are sharing the internet connection and are using xp home.thay do not have wireless.i tried rick's advise but that didnt work.i dont know if the file and print sharing is enabled,how do you do this?and how do you disable RPC?
  5. PanicX

    PanicX TechSpot Ambassador Posts: 669

    assuming that these are Windows XP computers, check that you've allowed for "File and Printer sharing" in the Firewall exceptions.
  6. bajpaiabhinav

    bajpaiabhinav TS Rookie

    Resolving RPC Error

    Restart your computer by using the Safe Mode startup option. To do this, follow these steps:a. Restart your computer, and when the Boot menu appears, press F8.
    b. Under Windows Advanced Options Menu, select Safe Mode, and then press ENTER.
    c. When the Boot menu appears again with the words "Safe Mode" displayed at the bottom of the menu, select the operating system that you want to start, and then press ENTER.

    2. Click Start, click Run, type regedit, and then click OK.
    3. In the left pane, locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\Current\System\CurrentControlSet\Enum\ROOT\LEGACY_RPCSS
    4. On the File menu, click Export.
    5. In the File name box, type a name for the registry file.
    6. In the Save in list, click the location where you want to save the registry file, and then click Save.
    7. Right-click LEGACY_RPCSS, click Delete, and in the Confirm Key Delete dialog box, click Yes.

    Note Do not delete any one of the following subkeys that may be found under the ROOT subkey:• MS_L2TPMINIPORT

    8. Exit Registry Editor.
    9. Restart your computer by using the Restart Windows Normally startup option.
    :knock: Bingoooooo!!!!!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...