TechSpot

Runescape error help

By magaman598
Jul 6, 2009
Topic Status:
Not open for further replies.
  1. When I play Runescape, I get this Error Log, I have no clue how to read it. I never had this happen before I had to Reinstall Windows (BOOT.INI problems) This is the first time I've gottent this Error Log.

    I Attached the Error Log with this Post, any help would be great.
  2. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    It's a memory access error according to your log. This can be caused by many things, but some potential reasons include failing memory RAM module (You can test RAM with memtest), graphics driver problem (update your video card drivers), a programming error (Update java?) and many other things.

    For future reference, if you have boot.ini problems, they can be fixed without reinstalling unless you have a more serious, underlying issue. I don't know if this is a connection or not, but memory access violations can also be caused by DEP. One method of disabling DEP is editing your boot.ini file... This wouldn't happen to have been the reason, would it? :)
  3. magaman598

    magaman598 TS Booster Topic Starter Posts: 275

    Thanks, and If I remember correctly, I have the most current Drivers for my GPU (I'm in the Process of checking right now.) I'll update the Java here in a Minute.

    Memtest will be running all night. =D

    Also, what is the DEP you mentioned?
  4. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    DEP is data execution prevention. It really shouldn't be the issue, especially since you're dealing with a browser-based game. I advise against doing this, but you can disable DEP for certain applications. In this case, I think you would have to disable it for Java.

    Again, warning: This is a really bad idea from a security perspective (Think: Viruses) and there shouldn't be a reason for you to disable it.. Java should work fine with DEP enabled. I'm listing this for the purpose of curiosity.
    • Start > Control Panel > System > Advanced tab > Settings
    • Click the "Data Execution" tab in the box that appears
    • Make sure "Turn on DEP" is selected for all programs and services, except the ones you select
    • Click Add
    • Browse to Java: C:\Program Files\Java\jre6\bin and click open.
    • Click OK and reboot
  5. magaman598

    magaman598 TS Booster Topic Starter Posts: 275

    Yea, I'm good, I don't really feeling like messing with DEP settings. (Thanks for the Explanation.)

    I got the lastest Drivers from Nvidia, and got the lastest Java, now time for Memtest, wish me luck! lol
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.