TechSpot

S.M.A.R.T problem with slave drive

By Hatrick
Aug 17, 2007
  1. After some problems with WinXP which resulted in the slave drive vanishing, I finally managed to get up and running again but, when booting, the following message appears:_-"Primary slave.Ultra DMA mode 3. SMART capable but command failed. Press F1 to resume". On pressing F1 the system then boots normally.

    Extended tests have been run twice on the disk with no problems, except the statement "Smart status - not available". Speedfan shows the same.

    My thinking is that this may be related to the 'main' BIOS, which gives the following information:-

    Primary IDE master - cd/dvd
    Primary IDE slave - the 80GB disk in question, which has yet to be formatted for use.
    Secondary master -cd/dvd
    Secondary slave - not detected
    Third master - 160GB disk containing the operating system and files.
    Fourth master - not detected.

    Details for the Primary Slave show S.M.A.R.T monitoring supported, and it is set to 'auto'

    The order of the items has, I think, changed since everything worked normally, probably as a result of my having to fix the mbr in the Recovery Console. I think it should be shown as 'Third IDE slave", although whether this will fix the SMART problem remains to be seen, but I can find no way of changing the order.

    This is foreign territory for me so any advice and help will be greatly appreciated.
     
  2. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    SMART monitors the condition of the drive and is supposed to warn that the drive is failing by measuring a number of conditions including things like the controller card. If SMART is reporting the drive as not responding to the SMART command then I would not trust the drive without first formatting it and then running the manufacturer's tests on it. Go to the manufacturer's website and download their free diagnostic software - if that reports it OK then I would use it and turn off the SMART check in the BIOS.
    You might find that once it is formatted, the SMART check reports it as OK.
     
  3. Hatrick

    Hatrick TS Rookie Topic Starter Posts: 90

    Thanks. I've run Western Digital's extended diagnostic test, twice, and it has passed both times. I'm saving the disk for my 99th attempt to install Linux - without trashing Windows so, for the time being I may just turn off SMART monitoring.
     
  4. Hatrick

    Hatrick TS Rookie Topic Starter Posts: 90

    Problem solved - almost. Formatted slave and turned off SMART monitoring in BIOS. Everything working.
    Thanks for advice.
     
  5. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Glad to be of help - did formatting clear the SMART error message?
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...